现在的位置: 首页 > 综合 > 正文

hdu 1711(KMP入门题)

2012年05月20日 ⁄ 综合 ⁄ 共 1546字 ⁄ 字号 评论关闭

以前看过KMP, 但是今天没有看资料, 自己想的,完全想通,感叹KMP的奇妙。

 

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7750    Accepted Submission(s): 3532

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

 

Sample Output
6
-1
 

 

Source
 

 

Recommend
lcy
 

 

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

int t[1001000];
int s[10100];
int save[10100];
int n,m;
int sum;

void prepare()
{
    save[1]=1;
    int j=1;
    for(int i=2;i<=m;i++)
    {
        while(s[j] != s[i]&&j!=1)
        {
            j = save[j-1];
        }
        if( s[j]==s[i] )
        {
            j++;
        }
        save[i]=j;
    }
}

int KMP()
{
    int j=1;
    for(int i=1;i<=n;i++)
    {
        while(s[j]!=t[i] && j!=1)
        {
            j=save[j-1];
        }
        if(s[j]==t[i])
        {
            j++;
        }
        if(j>m) 
        {
            return i-m+1;
        }
    }
    return -1;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        sum=0;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%d",&t[i]);
        for(int i=1;i<=m;i++)
            scanf("%d",&s[i]);
        prepare();
        printf("%d\n",KMP());
    }
    return 0;
}

 

抱歉!评论已关闭.