现在的位置: 首页 > 综合 > 正文

POJ 3252 Round Numbers(数位DP)

2012年07月03日 ⁄ 综合 ⁄ 共 2124字 ⁄ 字号 评论关闭
Round Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6983   Accepted: 2384

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6

Source

 
 
 
数位DP,很简单
直接组合也可以搞出来的
 
/*
 * POJ 3252
 * 转换成2进制中,0的个数不少于1的个数
 * 直接用排列组合的方法也可以出来
 */
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
int dp[40][40][40];
int bit[40];
int dfs(int pos,int num0,int num1,bool flag,bool z)
{
    if(pos==-1)return num0>=num1;
    if(!flag && dp[pos][num0][num1]!=-1)
        return dp[pos][num0][num1];
    int ans=0;
    int end=flag?bit[pos]:1;
    for(int i=0;i<=end;i++)
    {
        ans+=dfs(pos-1,(z&&i==0)?0:num0+(i==0),(z&&i==0)?0:num1+(i==1),flag&&i==end,z&&(i==0));
    }
    if(!flag)dp[pos][num0][num1]=ans;
    return ans;
}
int calc(int n)
{
    int len=0;
    while(n)
    {
        bit[len++]=n&1;
        n>>=1;
    }
    return dfs(len-1,0,0,1,1);
}
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int l,r;
    memset(dp,-1,sizeof(dp));
    while(scanf("%d%d",&l,&r)==2)
    {
        printf("%d\n",calc(r)-calc(l-1));
    }
    return 0;
}

 

 
 

抱歉!评论已关闭.