现在的位置: 首页 > 综合 > 正文

HDU 1228 A + B(水题)

2012年09月20日 ⁄ 综合 ⁄ 共 887字 ⁄ 字号 评论关闭

A + B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7615    Accepted Submission(s): 4307

Problem Description
读入两个小于100的正整数A和B,计算A+B.
需要注意的是:A和B的每一位数字由对应的英文单词给出.
 

 

Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出.
 

 

Output
对每个测试用例输出1行,即A+B的值.
 

 

Sample Input
one + two = three four + five six = zero seven + eight nine = zero + zero =
 

 

Sample Output
3 90 96
 

 

Source
 

 

Recommend
JGShining
 
 
 
很水的题目
练习使用了下map
#include<stdio.h>
#include<map>
#include<string.h>
#include<iostream>
using namespace std;
map<string,int>p;
int main()
{
int a,b;
string str;
p["zero"]=0;
p["one"]=1;
p["two"]=2;
p["three"]=3;
p["four"]=4;
p["five"]=5;
p["six"]=6;
p["seven"]=7;
p["eight"]=8;
p["nine"]=9;
while(cin>>str)
{
a=b=0;
a=p[str];
cin>>str;
while(str!="+")
{
a*=10;
a+=p[str];
cin>>str;
}
cin>>str;
while(str!="=")
{
b*=10;
b+=p[str];
cin>>str;
}
if(a==0&&b==0) break;
printf("%d\n",a+b);
}
return 0;
}

抱歉!评论已关闭.