现在的位置: 首页 > 综合 > 正文

HDOJ 题目1213 How Many Tables(并查集基础)

2016年10月06日 ⁄ 综合 ⁄ 共 1677字 ⁄ 字号 评论关闭

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13299    Accepted Submission(s): 6507

Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
2 4
 

Author
Ignatius.L
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1272 1856 1325 1233 1198 
并查集第二道,还是基础的模板
ac代码
#include<stdio.h>
int pre[1010];
int find(int x)
{
    int r=x,i=x,j;
    while(pre[r]!=r)
        r=pre[r];
    while(i!=r)
    {
        j=pre[i];
        pre[i]=r;
        i=j;
    }
    return r;
}
int main()
{
    int i,j,k,n,t,tm;
    /*for(i=0;i<=1010;i++)
    {
        pre[i]=i;
    }*/
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
		for(i=0;i<=n;i++)
			pre[i]=i;
        for(i=0;i<m;i++)
        {
            int a,b,fa,fb;
            scanf("%d%d",&a,&b);
            fa=find(a);
            fb=find(b);
            if(fa!=fb)
            {
               pre[fb]=fa;
                //n--;
            }
        }
		tm=0;
		for(i=1;i<=n;i++)
		{
			if(pre[i]==i)
				tm++;
		}
        printf("%d\n",tm);
    }
}

抱歉!评论已关闭.