现在的位置: 首页 > 综合 > 正文

Jobdu 题目1162:I Wanna Go Home

2017年05月08日 ⁄ 综合 ⁄ 共 2350字 ⁄ 字号 评论关闭

http://ac.jobdu.com/problem.php?pid=1162

题目描述:

    The country is facing a terrible civil war----cities in the country are divided into two parts supporting different leaders. As a merchant, Mr. M does not pay attention to politics but he actually knows the severe situation, and your task is to help him
reach home as soon as possible. 
    "For the sake of safety,", said Mr.M, "your route should contain at most 1 road which connects two cities of different camp."
    Would you please tell Mr. M at least how long will it take to reach his sweet home?

输入:

    The input contains multiple test cases.
    The first line of each case is an integer N (2<=N<=600), representing the number of cities in the country.
    The second line contains one integer M (0<=M<=10000), which is the number of roads.
    The following M lines are the information of the roads. Each line contains three integers A, B and T, which means the road between city A and city B will cost time T. T is in the range of [1,500].
    Next part contains N integers, which are either 1 or 2. The i-th integer shows the supporting leader of city i. 
    To simplify the problem, we assume that Mr. M starts from city 1 and his target is city 2. City 1 always supports leader 1 while city 2 is at the same side of leader 2. 
    Note that all roads are bidirectional and there is at most 1 road between two cities.
Input is ended with a case of N=0.

输出:

    For each test case, output one integer representing the minimum time to reach home.
    If it is impossible to reach home according to Mr. M's demands, output -1 instead.

样例输入:
2
1
1 2 100
1 2
3
3
1 2 100
1 3 40
2 3 50
1 2 1
5
5
3 1 200
5 3 150
2 5 160
4 3 170
4 2 170
1 2 2 2 1
0
样例输出:
100
90
540
注意到只能有从阵营1到阵营2方向的路线,这里在处理结点邻接链表时把从2到1的时间定为0,表示不可达,转化一下后还是Dijkstra问题:
#include <cstdio>
#include <vector>
using namespace std;
struct E{
	int next;
	int t;
};
vector<E> edge[10001];
bool mark[601];
int time[601];
int own[601];

int main(){
	int n, m;
	while (scanf("%d", &n) != EOF && n){
		for (int i = 1; i <= n; i++){
			edge[i].clear();
			mark[i] = false;
			time[i] = -1;
		}
		scanf("%d", &m);
		while (m--){
			int a, b, t;
			scanf("%d%d%d", &a, &b, &t);
			E tmp;
			tmp.t = t;
			tmp.next = b;
			edge[a].push_back(tmp);
			tmp.next = a;
			edge[b].push_back(tmp);
		}
		for (int i = 1; i <= n; i++)
			scanf("%d", &own[i]);
		mark[1] = true;
		time[1] = 0;
		int newP = 1;
		for (int i = 1; i < n; i++){
			for (int j = 0; j < edge[newP].size(); j++){
				int next = edge[newP][j].next;
				if (own[newP] == 2 && own[next] == 1)
					edge[newP][j].t = 0;
				int t = edge[newP][j].t;
				if (mark[next] == true || t == 0) continue;
				if (time[next] == -1 ||time[next] > time[newP] + t)
					time[next] = time[newP] + t;
			}
			int min = 1999999999;
			for (int j = 1; j <= n; j++){
				if (mark[j] == true || time[j] == -1) continue;
				if (time[j] < min){
					min = time[j];
					newP = j;
				}
			}
			mark[newP] = true;
		}
		if (time[2] != -1)
			printf("%d\n", time[2]);
		else
			printf("-1\n");
	}
	return 0;
}

抱歉!评论已关闭.