现在的位置: 首页 > 综合 > 正文

PAT 1073. Scientific Notation (20)

2017年05月08日 ⁄ 综合 ⁄ 共 1620字 ⁄ 字号 评论关闭

http://pat.zju.edu.cn/contests/pat-a-practise/1073

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9]"."[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one
digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input file contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros,

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

马乐个蛋蛋的~正数前面要去‘+’, 没注意到这个浪费了太多时间~~

#include <cstdio>
#include <iostream>
#include <string>
#include <sstream>
using namespace std;

int main(){
	string s, ans = "";
	getline(cin, s);
	if (s[0] == '-')
		ans += s[0];
	int indexE = s.find("E");
	string num = s.substr(1, indexE-1);
	char x = s[indexE + 1];
	string exp = s.substr(indexE+2, s.size() - indexE - 2);
	stringstream ss;
	ss << exp;
	int e;
	ss >> e;
	if (e == 0){
		cout << ans << num << endl;
		return 0;
	}
	if (x == '+'){
		if (e < num.size() - 2){
			ans = ans + num[0] + num.substr(2, e) + "." + num.substr(e + 2, num.size() - e - 2);
		}
		else{
			ans = ans + num[0] + num.substr(2, num.size()-2);
			for (int i = 0; i < e - num.size() + 2; i++)
				ans += "0";
		}
	}
	if (x == '-'){
		ans = ans + "0.";
		while (e-- != 1)
			ans += "0";
		ans = ans + num[0] + num.substr(2, num.size()-2);
	}
	cout << ans << endl;
	return 0;
}

抱歉!评论已关闭.