现在的位置: 首页 > 综合 > 正文

【PAT1032】Sharing 找两单词链表的相同后缀

2017年05月08日 ⁄ 综合 ⁄ 共 2508字 ⁄ 字号 评论关闭

1032. Sharing (25)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.


Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total
number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, andNext is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1
题意:

找出两个单词链表中,相同的后缀。

分析:

初期想法:Address
Data Next 把所有Node,建立一个multimap<Next,
Address> mm
多实例map,从-1开始寻找,直到找打某个key【Next】实例存在多个。代码提交后,可以通过3个case。发现问题应该出在:
所给出的Node可能多于2个单词链表!

现在思路把所有Node,建立一个map<Address,Next>的单实例map。根据给出的两个单词的头节点,遍历该单词所有节点并放置在一个stack中。然后,只需比较两个stack的头元素,同时循环pop操作直到发现两个栈的头元素不同。

代码:

#include <stdio.h>
#include <iostream>
#include <fstream>
#include <stack>
#include <iomanip>
#include <map>
using namespace std;

//ifstream fin("in.txt");
//#define cin fin

int main(){
	map<int,int> mm;
	int ad1,ad2,n;
	scanf("%d %d %d",&ad1,&ad2,&n);
	//cin>>ad1>>ad2>>n;
	int ad,adnext;
	char data;
	int i;

	for(i=0;i<n;i++)		//将所有节点放于map
	{
		scanf("%d %c %d",&ad,&data,&adnext);
		//cin>>ad>>data>>adnext;
		mm.insert(make_pair(ad,adnext));
	}

	stack<int> v1,v2;

	int searchitem = ad1;		//找到第一个单词链表,倒置放于栈中
	v1.push(searchitem);
	while(searchitem != -1)
	{
		map<int,int>::iterator iter = mm.find(searchitem);
		searchitem = iter->second;
		v1.push(searchitem);
		
	}
	searchitem = ad2;		//找到第二个单词链表,倒置放于栈中
	v2.push(searchitem);
	while(searchitem != -1)
	{
		map<int,int>::iterator iter = mm.find(searchitem);
		searchitem = iter->second;
		v2.push(searchitem);
	}

	int item = -1;
	while(v1.top() == v2.top())		//循环比较头元素
	{
		item = v1.top();
		v1.pop();
		v2.pop();
		if(v1.empty() || v2.empty()){
			break;
		}
	}

	if(item != -1)
	{
		//cout<<setw(5)<<setfill('0')<<item<<endl;		//格式化输出
		printf("%05d\n",item);
	}else{
		//cout<<-1<<endl;
		printf("-1\n");
	}
	system("pause");
	return 0;
}

抱歉!评论已关闭.