现在的位置: 首页 > 综合 > 正文

【PAT】1046. Shortest Distance (20)

2017年05月08日 ⁄ 综合 ⁄ 共 1453字 ⁄ 字号 评论关闭

1046. Shortest Distance (20)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN,
where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive
integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

题意:求一个环形路线的两两节点间最小距离。

思路:刚开始是最原始的一一累加,第三个case超时;后来想用DP,但在定义数组int dis[100001][100001]时报“数组太大”的错误;放弃DP了开始琢磨数据的规律,发现①环形的总长度是可求的②A到B之间的距离等于(A到0距离)减去(B到0距离)③任意节点到0的距离都可以在输入时求出。

代码如下:

#include <iostream>
#include <fstream>

using namespace std;

ifstream fin("in.txt");
#define cin fin

int main()
{
    int n;
	cin>>n;
	int* dis = new int[n+1];
	int d;
	int i;
	int sum = 0;
	for(i=0;i<n;i++)
	{
		cin>>d;
		dis[i+1] = sum;
		sum = sum + d;
	}

	int m;
	cin>>m;
	int begin,end;
	int total;
	for(i=0;i<m;i++)
	{
		cin>>begin>>end;
		if(begin>end)
		{
			total = dis[begin]-dis[end];
		}else
		{
			total = dis[end]-dis[begin];
		}

		if(sum-total > total)
		{
			cout<<total<<endl;
		}else
		{
			cout<<sum-total<<endl;
		}

	}
	system("PAUSE");
    return 0;
}

抱歉!评论已关闭.