现在的位置: 首页 > 综合 > 正文

poj3069 Saruman’s Army(贪心)

2017年06月07日 ⁄ 综合 ⁄ 共 2073字 ⁄ 字号 评论关闭
Saruman's Army
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4250   Accepted: 2183

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units,
and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units
of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s
army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positionsx1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n =
−1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed
to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

题意:可以等效于直线上有n个点 点 i的位置是Xi。从中若干个点标记,对每个点,在其距离为r的区域内必须有带有标记的点(自己本身带标记距离为0) 在满足条件情况下尽量少添加标记 ,问最少的标记
思路:我们从最左边开始 分析
  ------r-----r--------r
-o-o--x-----o-o-o--x-----------------------------------
    !可以看做新的起点 重复开始找
直到结束
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[1005];
int n,r;
void solve()
{
    sort(a,a+n);
    int i=0 ,ans=0;
    while(i<n)
    {
        int st=a[i++];//起点
        while(i<n&&a[i]<=r+st) i++;
        int pf=a[i-1];//标记点
        while(i<n&&a[i]<=r+pf) i++;//找下一个起点
        ans++;
    }
    cout<<ans<<endl;
}
int main()
{
    while(cin>>r>>n)
    {
        if(n==-1&&r==-1)
        break;
        for(int i=0;i<n;i++)
            cin>>a[i];
        solve();
    }

}

抱歉!评论已关闭.