现在的位置: 首页 > 综合 > 正文

hdu 1114 Piggy-Bank — 完全背包

2017年10月03日 ⁄ 综合 ⁄ 共 2727字 ⁄ 字号 评论关闭

Piggy-Bank

Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes
all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to
be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

 


Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights
are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are
exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 


Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight
cannot be reached exactly, print a line "This is impossible.". 
 


Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 


Sample Output
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
 

代码:

/**
*   完全背包:
*             有N种物品和一个容量为V的背包,每种物品都有无限件可用。
*             放入第 i 种物品 的费用是 Ci,价值是 Wi。求解:
*             将哪些物品装入背包,可使这些物品的耗费的费用总和不超过背包容量,且价值总和最大
*   伪码:
*             F[0..V ]←0 
*             for i ← 1 to N 
*             for v ← Ci to V 
*             F[v] ←max(F[v],F[v−Ci] + Wi) 
*   
*/
#include <stdio.h>
#include <string.h>
#define maxn 10005
int p[maxn], w[maxn], dp[maxn];
int min(int a, int b)
{
	if (a < b)return a;
	return b;
}
int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		int E, F, V;
		scanf("%d%d", &E, &F);
		V = F - E;
		for (int i = 1; i <= V; i++)
			dp[i] = 9999999;
		dp[0] = 0;
		int n;
		scanf("%d", &n);
		for (int i = 1; i <= n; i++)
			scanf("%d%d", &p[i], &w[i]);
		for (int i = 1; i <= n; i++)
		for (int v = w[i]; v <= V; v++){
			dp[v] = min(dp[v], dp[v - w[i]] + p[i]);
		}
		if (dp[V] == 9999999)
			printf("This is impossible.\n");
		else
			printf("The minimum amount of money in the piggy-bank is %d.\n", dp[V]);
	}
	return 0;
}

抱歉!评论已关闭.