现在的位置: 首页 > 综合 > 正文

hdu 2085 数塔 — dp模板题

2017年10月03日 ⁄ 综合 ⁄ 共 1007字 ⁄ 字号 评论关闭

数塔

Problem Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?

已经告诉你了,这是个DP的题目,你能AC吗?

 


Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
 


Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
 


Sample Input
1 5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
 


Sample Output
30
 

/**
*  dp 模板题 
*  dp两个要素: 
*  (1)最优子结构性质
*  (2)子问题重叠性质 
*  递归关系:  dp[x][y]=max(dp[x-1][y-1],dp[x-1][y])+a[x][y];  表示从顶层到达x层的第y个元素的数字和
*/
#include <stdio.h>
#include <string.h>
#include <limits.h>
#define maxn 105
int max(int a, int b){
	if (a > b) return a;
	return b;
}
int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		int dp[maxn][maxn], a[maxn][maxn];
		int n;
		scanf("%d", &n);
		for (int k = 1; k <= n; k++)
		for (int i = 1; i <= k; i++)
			scanf("%d", &a[k][i]);
		memset(dp, 0, sizeof(dp));
		dp[1][1] = a[1][1];
		for (int x = 2; x <= n; x++)
		for (int y = 1; y <= x; y++){
			if (1 == y){ dp[x][y] = dp[x - 1][y] + a[x][y]; continue; }
			if (x == y){ dp[x][y] = dp[x - 1][y - 1] + a[x][y]; continue; }
			dp[x][y] = max(dp[x - 1][y - 1], dp[x - 1][y]) + a[x][y];
		}
		int ans = -1;
		for (int i = 1; i <= n; i++){
			if (ans < dp[n][i])
				ans = dp[n][i];
		}
		printf("%d\n", ans);
	}
	return 0;
}

抱歉!评论已关闭.