现在的位置: 首页 > 综合 > 正文

PAT 1063. Set Similarity (25)

2017年10月12日 ⁄ 综合 ⁄ 共 2102字 ⁄ 字号 评论关闭

http://pat.zju.edu.cn/contests/pat-a-practise/1063

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets,
and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range
[0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated
by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%
#include <cstdio>
#include <set>
using namespace std;
set<int> s[50];
int main(){
	//freopen("G:\\input.in", "r", stdin);
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; ++i){
		int num, x;
		for (scanf("%d", &num); num; --num){
			scanf("%d", &x);
			s[i].insert(x);
		}
	}
	int k;
	for (scanf("%d", &k); k; --k){
		int a, b;
		scanf("%d%d", &a, &b);
		int counta = s[a - 1].size(), countb = s[b - 1].size();
		int cnt = 0;
		for (set<int>::iterator iter = s[a - 1].begin(); iter != s[a - 1].end(); ++iter){
			if (s[b - 1].find(*iter) != s[b - 1].end())
				cnt++;
		}
		printf("%.1lf%%\n", cnt*1.0/(counta+countb-cnt)*100);
	}
	return 0;
}

使用stl set_intersection set_union:

#include <cstdio>
#include <iostream>
#include <iomanip>
#include <algorithm>
#include <iterator>
#include <set>
using namespace std;
set<int> s[50];
int main(){
	//freopen("G:\\input.in", "r", stdin);
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; ++i){
		int num, x;
		for (scanf("%d", &num); num; --num){
			scanf("%d", &x);
			s[i].insert(x);
		}
	}
	int k;
	for (scanf("%d", &k); k; --k){
		int a, b;
		scanf("%d%d", &a, &b);
		set<int> inter, uni;
		set_intersection(s[a-1].begin(), s[a-1].end(), s[b-1].begin(), s[b-1].end(), inserter(inter, inter.begin()));
		//set_union(s[a-1].begin(), s[a-1].end(), s[b-1].begin(), s[b-1].end(), inserter(uni, uni.begin()));
		cout << setiosflags(ios::fixed) << setprecision(1) << inter.size() *100.0 / (s[a-1].size() + s[b-1].size() - inter.size()) << "%" << endl;
	}
	return 0;
}

抱歉!评论已关闭.