现在的位置: 首页 > 综合 > 正文

【HDU】2896 病毒侵袭 AC自动机

2017年10月15日 ⁄ 综合 ⁄ 共 2667字 ⁄ 字号 评论关闭

病毒侵袭

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10087    Accepted Submission(s): 2612

Problem Description

当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋——我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~
但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。
万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~
 


Input

第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在20—200之间。
每个病毒都有一个编号,依此为1—N。
不同编号的病毒特征码不会相同。
在这之后一行,有一个整数M(1<=M<=1000),表示网站数。
接下来M行,每行表示一个网站源码,源码字符串长度在7000—10000之间。
每个网站都有一个编号,依此为1—M。
以上字符串中字符都是ASCII码可见字符(不包括回车)。
 


Output

依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。
web 网站编号: 病毒编号 病毒编号 …
冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。
最后一行输出统计信息,如下格式
total: 带病毒网站数
冒号后有一个空格。
 


Sample Input
3 aaa bbb ccc 2 aaabbbccc bbaacc
 


Sample Output
web 1: 1 2 3 total: 1
 


Source

2009 Multi-University Training
Contest 10 - Host by NIT

传送门:【HDU】2896 病毒侵袭

题目分析:AC自动机模板题。PE了两发我会乱说QUQ。。。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;

#define clear( A , X ) memset ( A , X , sizeof A )
#define REP( I , N ) for ( int I = 0 ; I < N ; ++ I )
#define CHARREP( I ) for ( int I = 0 ; buf[I] ; ++ I )

const int maxW = 128 ;
const int maxN = 512 ;
const int maxS = 10005 ;

//==========================================================
struct Trie {
	int next[maxN << 8][maxW] ;
	int fail[maxN << 8] ;
	int end[maxN << 8] ;
	int Q[maxN << 8] ;
	bool vis[maxN] ;
	int head , tail ;
	int P , root ;
	
	int New () {
		REP ( i , maxW ) next[P][i] = -1 ;
		end[P] = -1 ;
		return P ++ ;
	}//New
	
	void Init () {
		P = 0 ;
		root = New () ;
	}//Init
	
	void Insert ( char buf[] , int idx ) {
		int now = root ;
		CHARREP ( i ) {
			if ( next[now][buf[i]] == -1 ) next[now][buf[i]] = New () ;
			now = next[now][buf[i]] ;
		}
		end[now] = idx ;
	}//Insert
	
	void Build () {
		head = tail = 0 ;
		fail[root] = root ;
		REP ( i , maxW ) {
			if ( next[root][i] == -1 ) next[root][i] = root ;
			else {
				fail[next[root][i]] = root ;
				Q[tail ++] = next[root][i] ;
			}
		}
		while ( head != tail ) {
			int now = Q[head ++] ;
			REP ( i , maxW ) {
				if ( next[now][i] == -1 ) next[now][i] = next[fail[now]][i] ;
				else {
					fail[next[now][i]] = next[fail[now]][i] ;
					Q[tail ++] = next[now][i] ;
				}
			}
		}
	}//Build
	
	int Query ( char buf[] , int n , int cas ) {
		int now = root ;
		clear ( vis , 0 ) ;
		CHARREP ( i ) {
			now = next[now][buf[i]] ;
			int tmp = now ;
			while ( tmp != root ) {
				if ( end[tmp] != -1 ) vis[end[tmp]] = 1 ;
				tmp = fail[tmp] ;
			}
		}
		int res = 0 , flag = 0 ;
		REP ( i , n ) if ( vis[i] ) {
			if ( !flag ) {
				printf ( "web %d:" , cas ) ;
				flag = 1 ;
			}
			++ res ;
			printf ( " %d" , i + 1 ) ;
		}
		if ( res ) printf ( "\n" ) ;
		return res ;
	}//Query
} ;
//==========================================================

Trie AC ;
char buf[maxS] ;

void Work () {
	int n , m ;
	while ( ~scanf ( "%d" , &n ) ) {
		AC.Init () ;
		REP ( i , n ) {
			scanf ( "%s" , buf ) ;
			AC.Insert ( buf , i ) ;
		}
		AC.Build () ;
		scanf ( "%d" , &m ) ;
		int res = 0 ;
		REP ( i , m ) {
			scanf ( "%s" , buf ) ;
			if ( AC.Query ( buf , n , i + 1 ) ) ++ res ;
		}
		printf ( "total: %d\n" , res ) ;
	}
}//Work

int main () {
	Work () ;
	return 0 ;
}//main

抱歉!评论已关闭.