现在的位置: 首页 > 综合 > 正文

【POJ】2367 Genealogical tree 拓扑排序

2017年10月15日 ⁄ 综合 ⁄ 共 2805字 ⁄ 字号 评论关闭
Genealogical tree
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 2729
Accepted: 1835
Special Judge

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent
as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than
to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake
first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.

Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council
are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by
spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard
output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

Source

Ural State University Internal Contest October'2000 Junior
Session

传送门:【POJ】2367 Genealogical tree

题目分析:拓扑排序基础题。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;

#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REPV( i , a , b ) for ( int i = a ; i >= b ; -- i )
#define clear( a , x ) memset ( a , x , sizeof a )
#define copy( a , b ) memcpy ( a , b , sizeof a )

typedef long long Int ; 

const int MAXN = 105 ;
const int MAXE = 1000000 ;
const int INF = 0x3f3f3f3f ;

struct Edge {
	int v , n ;
} ;

Edge edge[MAXE] ;
int adj[MAXN] , cntE ;
int in[MAXN] ;
int Q[MAXN] , head , tail ;
int n , m ;
int ans[MAXN] ;

void addedge ( int u , int v ) {
	edge[cntE].v = v ; edge[cntE].n = adj[u] ; adj[u] = cntE ++ ;
}

void DAG () {
	head = tail = 0 ;
	int cnt = 0 ;
	REPF ( i , 1 , n )
		if ( !in[i] )
			Q[tail ++] = i ;
	while ( head != tail ) {
		int u = Q[head ++] ;
		ans[cnt ++] = u ;
		for ( int i = adj[u] ; ~i ; i = edge[i].n ) {
			int v = edge[i].v ;
			if ( 0 == ( -- in[v] ) )
				Q[tail ++] = v ;
		}
	}
	REP ( i , cnt )
		printf ( "%d%c" , ans[i] , i < cnt - 1 ? ' ' : '\n' ) ;
}

void work () {
	int u , v ;
	while ( ~scanf ( "%d" , &n ) ) {
		clear ( adj , -1 ) ;
		clear ( in , 0 ) ;
		cntE = 0 ;
		REPF ( u , 1 , n ) {
			while ( 1 ) {
				scanf ( "%d" , &v ) ;
				if ( !v )
					break ;
				++ in[v] ;
				addedge ( u , v ) ;
			}
		}
		DAG () ;
	}
}

int main () {
	work () ;
	return 0 ;
}

抱歉!评论已关闭.