现在的位置: 首页 > 综合 > 正文

【HDU】3342 Legal or Not 拓扑排序

2017年10月15日 ⁄ 综合 ⁄ 共 2448字 ⁄ 字号 评论关闭

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3988    Accepted Submission(s): 1793

Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line
to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But
then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian
is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

 


Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains
a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 


Output

For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 


Sample Input
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 


Sample Output
YES NO
 


Author

QiuQiu@NJFU
 


Source

HDOJ Monthly Contest – 2010.03.06

题目分析:拓扑排序模板题

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;

#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REPV( i , a , b ) for ( int i = a ; i >= b ; -- i )
#define clear( a , x ) memset ( a , x , sizeof a )

typedef long long Int ; 

const int MAXN = 10005 ;
const int MAXE = 1000000 ;

struct Edge {
	int v , n ;
} ;

Edge edge[MAXE] ;
int adj[MAXN] , cntE ;
int in[MAXN] ;
int Q[MAXN] , head , tail ;
int cnt ;
int n , m ;

void addedge ( int u , int v ) {
	edge[cntE].v = v ; edge[cntE].n = adj[u] ; adj[u] = cntE ++ ;
}

void DAG () {
	head = tail = 0 ;
	cnt = 0 ;
	REP ( i , n )
		if ( !in[i] )
			Q[tail ++] = i ;
	while ( head != tail ) {
		int u = Q[head ++] ;
		cnt ++ ;
		for ( int i = adj[u] ; ~i ; i = edge[i].n ) {
			int v = edge[i].v ;
			if ( 0 == ( -- in[v] ) )
				Q[tail ++] = v ;
		}
	}
	printf ( cnt < n ? "NO\n" : "YES\n" ) ;
}

void work () {
	int u , v ;
	while ( ~scanf ( "%d%d" , &n , &m ) && ( n || m ) ) {
		clear ( adj , -1 ) ;
		clear ( in , 0 ) ;
		cntE = 0 ;
		while ( m -- ) {
			scanf ( "%d%d" , &u , &v ) ;
			++ in[v] ;
			addedge ( u , v ) ;
		}
		DAG () ;
	}
}

int main () {
	work () ;
	return 0 ;
}

抱歉!评论已关闭.