现在的位置: 首页 > 综合 > 正文

【POJ】2482 Stars in Your Window 线段树 + 扫描线

2017年10月16日 ⁄ 综合 ⁄ 共 5763字 ⁄ 字号 评论关闭
Stars in Your Window
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 9473
Accepted: 2617

Description

Fleeting time does not blur my memory of you. Can it really be 4 years since I first saw you? I still remember, vividly, on the beautiful Zhuhai Campus, 4 years ago, from the moment I saw you smile,
as you were walking out of the classroom and turned your head back, with the soft sunset glow shining on your rosy cheek, I knew, I knew that I was already drunk on you. Then, after several months’ observation and prying, your grace and your wisdom, your attitude
to life and your aspiration for future were all strongly impressed on my memory. You were the glamorous and sunny girl whom I always dream of to share the rest of my life with. Alas, actually you were far beyond my wildest dreams and I had no idea about how
to bridge that gulf between you and me. So I schemed nothing but to wait, to wait for an appropriate opportunity. Till now — the arrival of graduation, I realize I am such an idiot that one should create the opportunity and seize it instead of just waiting.

These days, having parted with friends, roommates and classmates one after another, I still cannot believe the fact that after waving hands, these familiar faces will soon vanish from our life and become no more than a memory. I will move out from school tomorrow.
And you are planning to fly far far away, to pursue your future and fulfill your dreams. Perhaps we will not meet each other any more if without fate and luck. So tonight, I was wandering around your dormitory building hoping to meet you there by chance. But
contradictorily, your appearance must quicken my heartbeat and my clumsy tongue might be not able to belch out a word. I cannot remember how many times I have passed your dormitory building both in Zhuhai and Guangzhou, and each time aspired to see you appear
in the balcony or your silhouette that cast on the window. I cannot remember how many times this idea comes to my mind: call her out to have dinner or at least a conversation. But each time, thinking of your excellence and my commonness, the predominance of
timidity over courage drove me leave silently.

Graduation, means the end of life in university, the end of these glorious, romantic years. Your lovely smile which is my original incentive to work hard and this unrequited love will be both sealed as a memory in the deep of my heart and my mind. Graduation,
also means a start of new life, a footprint on the way to bright prospect. I truly hope you will be happy everyday abroad and everything goes well. Meanwhile, I will try to get out from puerility and become more sophisticated. To pursue my own love and happiness
here in reality will be my ideal I never desert.

Farewell, my princess!

If someday, somewhere, we have a chance to gather, even as gray-haired man and woman, at that time, I hope we can be good friends to share this memory proudly to relight the youthful and joyful emotions. If this chance never comes, I wish I were the stars in
the sky and twinkling in your window, to bless you far away, as friends, to accompany you every night, sharing the sweet dreams or going through the nightmares together.



Here comes the problem: Assume the sky is a flat plane. All the stars lie on it with a location (x, y). for each star, there is a grade ranging from 1 to 100, representing its brightness, where 100 is the brightest and 1 is the weakest. The window is a rectangle
whose edges are parallel to the x-axis or y-axis. Your task is to tell where I should put the window in order to maximize the sum of the brightness of the stars within the window. Note, the stars which are right on the edge of the window does not count. The
window can be translated but rotation is not allowed.

Input

There are several test cases in the input. The first line of each case contains 3 integers: n, W, H, indicating the number of stars, the horizontal length and the vertical height of the rectangle-shaped
window. Then n lines follow, with 3 integers each: x, y, c, telling the location (x, y) and the brightness of each star. No two stars are on the same point.

There are at least 1 and at most 10000 stars in the sky. 1<=W,H<=1000000, 0<=x,y<2^31.

Output

For each test case, output the maximum brightness in a single line.

Sample Input

3 5 4
1 2 3
2 3 2
6 3 1
3 5 4
1 2 3
2 3 2
5 3 1

Sample Output

5
6

Source

POJ Contest,Author:kinfkong@ZSU

传送门:【POJ】2482  Stars in Your Window

题目大意:给你平面上n个星星,每个星星有一个权值,让你用宽为W,高为H的矩形去框住权值和尽量大的星星(矩形边上的星星不算),其中矩形与坐标轴平行且不能旋转。问你最多能得到的最大的权值和是多少。

题目分析:将每个星星 i 作为W*H矩形的左下角,权值为val[ i ],并在矩形的右上角设立一个权值为-val[ i ]的星星,这样这两颗星星构成了一个矩形,将x轴离散化,按y轴从小到大排序,得到一系列平行于x轴的线段,然后按照y轴升序扫描这些线段,最大值就是覆盖的线段中权值和最大的那一段。需要注意的是矩形边上的星星不算在内,所以每次更新的线段从L ~ R-1。另外还需注意当删除与添加出现在同一高度的时候,先删除后添加。并且,题目虽然说x,y范围不超过int,但是加上W或H以后是可能会超过的,那些抱怨数据超出范围的我也不多说了,自己读题不严谨罢了。

PS:强烈建议阅读一下题面,文章写的很美哦~

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;

#define ls ( o << 1 )
#define rs ( o << 1 | 1 )
#define lson ls , l , m
#define rson rs , m + 1 , r
#define rt o , l , r
#define root( n )  1 , 1 , n
#define mid ( ( l + r ) >> 1 )
#define clear( a , x ) memset ( a , x , sizeof a )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REPV( i , a , b ) for ( int i = a ; i >= b ; -- i )

typedef long long LL ;

const int MAXN = 20005 ;

struct Line {
	int l , r , f ;
	LL h ;
	
	Line ( int L = 0 , int R = 0 , LL H = 0 , int F = 0 ) : 
		l ( L ) , r ( R ) , h ( H ) , f ( F ) {}

	bool operator < ( const Line &a ) const {
		return h == a.h ? f < a.f : h < a.h ;
	}
} ;

struct Point {
	int x , y , bright ;
	void input () {
		scanf ( "%d%d%d" , &x , &y , &bright ) ;
	}
} ;

Line line[MAXN] ;
Point node[MAXN] ;
LL a[MAXN] ;
int add[MAXN << 2] , mmax[MAXN << 2] ;

void pushUp ( int o ) {
	mmax[o] = max ( mmax[ls] , mmax[rs] ) ;
}

void pushDown ( int o ) {
	if ( add[o] ) {
		add[ls] += add[o] ;
		add[rs] += add[o] ;
		mmax[ls] += add[o] ;
		mmax[rs] += add[o] ;
		add[o] = 0 ;
	}
}

void update ( int x , int L , int R , int o , int l , int r ) {
	if ( L <= l && r <= R ) {
		mmax[o] += x ;
		add[o] += x ;
		return ;
	}
	pushDown ( o ) ;
	int m = mid ;
	if ( L <= m )
		update ( x , L , R , lson ) ;
	if ( m <  R )
		update ( x , L , R , rson ) ;
	pushUp ( o ) ;
}

int unique ( LL a[] , int n ) {
	sort ( a + 1 , a + n + 1 ) ;
	int cnt = 1 ;
	REPF ( i , 2 , n )
		if ( a[i] != a[cnt] )
			a[++ cnt] = a[i] ;
	return cnt ;
}

int binary_search ( LL x , int l , int r ) {
	while ( l < r ) {
		int m = mid ;
		if ( a[m] >= x )
			r = m ;
		else
			l = m + 1 ;
	}
	return l ;
}

void work () {
	int  n , W , H ;
	int cnt , m , res ;
	while ( ~scanf ( "%d%d%d" , &n , &W , &H ) ) {
		clear ( mmax , 0 ) ;
		clear ( add , 0 ) ;
		cnt = 0 ;
		REP ( i , n ) {
			node[i].input () ;
			a[++ cnt] = ( LL ) node[i].x ;
			a[++ cnt] = ( LL ) node[i].x + W ;
		}
		cnt = unique ( a , cnt ) ;
		m = 0 ;
		REP ( i , n ) {
			int x1 = binary_search ( ( LL ) node[i].x     , 1 , cnt + 1 ) ;
			int x2 = binary_search ( ( LL ) node[i].x + W , 1 , cnt + 1 ) ;
			LL y1 = ( LL ) node[i].y ;
			LL y2 = ( LL ) node[i].y + H ;
			line[m ++] = Line ( x1 , x2 , y1 ,  node[i].bright ) ;
			line[m ++] = Line ( x1 , x2 , y2 , -node[i].bright ) ;
		}
		sort ( line , line + m ) ;
		res = 0 ;
		REP ( i , m ) {
			update ( line[i].f , line[i].l , line[i].r - 1 , root ( cnt ) ) ;
			res = max ( res , mmax[1] ) ;
		}
		printf ( "%d\n" , res ) ;
	}
}

int main () {
	work () ;
	return 0 ;
}

抱歉!评论已关闭.