现在的位置: 首页 > 综合 > 正文

POJ 2431 Expedition

2017年10月17日 ⁄ 综合 ⁄ 共 2436字 ⁄ 字号 评论关闭
Expedition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6209   Accepted: 1860

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance
it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows
can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that
there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply
up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source

思路:优先队列+贪心
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
using namespace std;

const int maxn = 10010;
struct node
{
	int dist, fuel;
};
node position[maxn];

int n, L, P;

bool cmp(const node &a, const node &b)
{
	return a.dist > b.dist;
}



int main()
{
	
	while(scanf("%d", &n) != EOF)
	{
		priority_queue<int> heap;
		for(int i = 0; i < n; i++)
			scanf("%d %d", &position[i].dist, &position[i].fuel);
		sort(position, position + n, cmp);
		scanf("%d %d", &L, &P);
		int t = 0;
		heap.push(P);
		int index = 0;
		while(L > 0 && !heap.empty())
		{
			t++;
			int tmp = heap.top();
			heap.pop();
			L -= tmp;
			while(index < n && L <= position[index].dist)
				heap.push(position[index++].fuel);
		}
		printf("%d\n", L <= 0? t - 1: -1);
	}
	
	return 0;
}

抱歉!评论已关闭.