现在的位置: 首页 > 综合 > 正文

POJ 3660 floyd算法统计无关点个数

2017年10月17日 ⁄ 综合 ⁄ 共 1913字 ⁄ 字号 评论关闭
Cow Contest
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3613   Accepted: 1911

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cowA has a greater skill level than cow
B (1 ≤ AN; 1 ≤BN; A
B), then cow A will always beat cowB.

Farmer John is trying to rank the cows by skill level. Given a list the results ofM (1 ≤
M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer,A, is the winner) of a single round of competition:
A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source

这道题的题题意很明了
    给定n位大牛,然后在给出他们的m个关系,(关系是A强于B)
然后输出能够确定能力排名的大牛个数
解释一下样例:
    按照题目所叙述可以画出一个网络图(路径就用A->B的单向路线)可以确定5是最弱的,而且还可以看到2只比5更强,所以倒数一二名是可以确定的,但是另外三个点,我们只知道4比3要强,但是不知道4和1的强弱关系,同理3和1也无法判断,所以样例输出2
 
 
我的思路:
这道题我写的很顺利,大概花了不到20分钟就AC了。。。用的是floyd算法
 
我们首先观察到数据规模比较小是100的,所以100^3是可以满足题意的,我们先用floyd算法求出最短路的矩阵path[i][j],然后通过这个矩阵依次判断每一个点A是否存在有和他完全没有关系的点即是说path[a][b]==-1且path[b][a]==-1,最后统计这种点的数量用n减去就可以了
 
我的代码;
#include<stdio.h>
#include<string.h>

int n,m;
int path[105][105];

void floyd()
{
	int i,j,k;
	for(k=1;k<=n;k++)
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(path[i][k]!=-1&&path[k][j]!=-1)
				{
					if(path[i][j]==-1||path[i][j]<path[i][k]+path[k][j])
						path[i][j]=path[i][k]+path[k][j];
				}
			}
}

int main()
{
	int i,a,b,ans=0,j;
	memset(path,-1,sizeof(path));
	scanf("%d%d",&n,&m);
	for(i=1;i<=m;i++)
	{
		scanf("%d%d",&a,&b);
		path[a][b]=1;
	}
	floyd();
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
		{
			if(i==j)
				continue;
			if(path[i][j]==-1&&path[j][i]==-1)
			{
				ans++;
				break;
			}
		}
	}
	printf("%d/n",n-ans);
	return 0;
}

抱歉!评论已关闭.