现在的位置: 首页 > 综合 > 正文

HDOJ 5119 Happy Matt Friends DP

2017年10月18日 ⁄ 综合 ⁄ 共 1687字 ⁄ 字号 评论关闭

N*M暴力DP....

Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others)    Memory Limit: 510000/510000 K (Java/Others)
Total Submission(s): 82    Accepted Submission(s): 34


Problem Description
Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.

 


Input
The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.

 


Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
 


Sample Input
2 3 2 1 2 3 3 3 1 2 3
 


Sample Output
Case #1: 4 Case #2: 2
Hint
In the first sample, Matt can win by selecting: friend with number 1 and friend with number 2. The xor sum is 3. friend with number 1 and friend with number 3. The xor sum is 2. friend with number 2. The xor sum is 2. friend with number 3. The xor sum is 3. Hence, the answer is 4.
 


Source
 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long int LL;

LL dp[2][1<<20+1];
int a[100];
int n,m;

int main()
{
    int T_T,cas=1;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%d%d",&n,&m);
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf("%d",a+i);
        int now=1,pre=0;
        dp[0][0]=1LL;
        for(int i=1;i<=n;i++)
        {
            memset(dp[now],0,sizeof(dp[now]));
            for(int j=0;j<=(1<<20);j++)
            {
                if(dp[pre][j])
                {
                    int x=j^a[i];
                    dp[now][x]+=dp[pre][j];
                    dp[now][j]+=dp[pre][j];
                }
            }
            swap(now,pre);
        }
        LL ans=0;
        for(int i=m;i<=(1<<20);i++)
            ans+=dp[pre][i];
        printf("Case #%d: %I64d\n",cas++,ans);
    }
    return 0;
}

抱歉!评论已关闭.