现在的位置: 首页 > 综合 > 正文

HDOJ 4788 Hard Disk Drive

2017年10月18日 ⁄ 综合 ⁄ 共 1858字 ⁄ 字号 评论关闭

Python3打表。。。。

Hard Disk Drive

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1044    Accepted Submission(s): 564


Problem Description
  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks
that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.
 


Input
  The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.
 


Output
  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.
 


Sample Input
2 100[MB] 1[B]
 


Sample Output
Case #1: 4.63% Case #2: 0.00%
Hint
 


Source
 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

char xxx[9]={'B','K','M','G','T','P','E','Z','Y'};
double ans[9]={0.0000,0.0234375,0.0463256,
               0.0686774,0.090505,0.111821,
               0.132638,0.1529670,0.172819};

int main()
{
    int T_T,cas=1;
    scanf("%d",&T_T);
    while(T_T--)
    {
        char op[50],SG;
        scanf("%s",op);
        for(int i=0;;i++)
        {
            if(op[i]=='[')
            {
                SG=op[i+1];
                break;
            }
        }
        for(int i=0;i<9;i++)
        {
            if(SG==xxx[i])
            {
                printf("Case #%d: %.2lf%%\n",cas++,ans[i]*100.);
                break;
            }
        }
    }
    return 0;
}

抱歉!评论已关闭.