现在的位置: 首页 > 综合 > 正文

Minesweeper

2017年11月12日 ⁄ 综合 ⁄ 共 1946字 ⁄ 字号 评论关闭

 Problem B: Minesweeper 

The Problem

Have you ever played Minesweeper? It's a cute little game which comes within a certain Operating System which name we can't really remember. Well, the goal of the game is to find where are all the mines within a MxN field. To help you, the game shows a number
in a square which tells you how many mines there are adjacent to that square. For instance, supose the following 4x4 field with 2 mines (which are represented by an * character):

*...
....
.*..
....

If we would represent the same field placing the hint numbers described above, we would end up with:

*100
2210
1*10
1110

As you may have already noticed, each square may have at most 8 adjacent squares.

The Input

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m (0 < n,m <= 100) which stands for the number of lines and columns of the field respectively. The next n lines contains exactly m characters
and represent the field. Each safe square is represented by an "." character (without the quotes) and each mine square is represented by an "*" character (also without the quotes). The first field line where n = m = 0 represents the end of input and should
not be processed.

The Output

For each field, you must print the following message in a line alone:

Field #x:

Where x stands for the number of the field (starting from 1). The next n lines should contain the field with the "." characters replaced by the number of adjacent mines to that square. There must be an empty line between field outputs.

Sample Input

4 4
*...
....
.*..
....
3 5
**...
.....
.*...
0 0

Sample Output

Field #1:
*100
2210
1*10
1110

Field #2:
**100
33200
1*100

 

位向量解决 

 

#include <stdio.h>
#include <string.h>
#define max 100
char mine[max][max];
int main()
{
    int m, n, i, j, k, count = 1;
    int px[8] = {-1,-1,-1, 0, 0, 1, 1, 1};
    int py[8] = {-1, 0, 1,-1, 1,-1, 0, 1};
    while (scanf("%d %d", &n, &m) && (m || n))
    {
          memset(mine, '.', sizeof(mine));
          for (i = 0; i < n; i++)
              for (j = 0; j < m; j++)
                  scanf(" %c", &mine[i][j]);
          for (i = 0; i < n; i++)
              for (j = 0; j < m; j++)
              {
                  int tmp = 0;
                  if (mine[i][j] == '.')
                     for (k = 0; k < 8; k++)
                     {
                         
                         if (mine[i+px[k]][j+py[k]] == '*')
                            tmp++;
                         mine[i][j] = tmp + '0';
                     }
              }
          if (count != 1)
            printf("\n");
          printf("Field #%d:\n", count++);
          for (i = 0; i < n; i++)
          {
              for (j = 0; j < m; j++)
                  printf("%c", mine[i][j]);
              printf("\n");
          }
    }
    return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.