现在的位置: 首页 > 综合 > 正文

poj 2632 Crashing Robots

2017年11月18日 ⁄ 综合 ⁄ 共 3236字 ⁄ 字号 评论关闭
Crashing Robots
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7484   Accepted: 3272

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor
space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are
processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 
 
Figure 1: The starting positions of the robots in the sample warehouse


Finally there are M lines, giving the instructions in sequential order. 
An instruction has the following format: 
< robot #> < action> < repeat> 
Where is one of 
  • L: turn left 90 degrees, 
  • R: turn right 90 degrees, or 
  • F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case: 
  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.) 
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot. 
  • OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2
题意:就是有个仓库 里面用机器人搬东西 现在告诉你仓库大小 对机器人进行操作的次数 机器人位置和朝向 对机器人进行的操作
问你 :机器人相撞否 或者 会撞墙否 会成功否
(吐槽: 模拟了一天 用了两种思路 最后发现撞完墙或者碰撞后就不用管了 搞得我还以为输入输出错了 卧槽)
思路 :模拟模拟。。。。
#include<stdio.h>
#include<cstring>
#include<iostream>
using namespace std;
int ma[110][110];
struct robot
{
    int x,y;
    char d;
} r[110];
int main()
{
    int t;
    int a,b;
    int n,m;
    int id,tms;
    char orz;
    cin>>t;
    while(t--)
    {
        memset(ma,0,sizeof(ma));
        cin>>a>>b;
        cin>>n>>m;
        for(int i=1; i<=n; i++)
        {
            cin>>r[i].x>>r[i].y>>r[i].d;
            ma[r[i].x][r[i].y]=i;
        }

        int flag=1;

        for(int i=1; i<=m; i++)
        {
            cin>>id>>orz>>tms;
            if(flag)
            {
                for(int j=1; j<=tms; j++)
                {
                    if(orz=='L')
                    {
                        if(r[id].d=='N')
                            r[id].d='W';
                        else if(r[id].d=='W')
                            r[id].d='S';
                        else if(r[id].d=='S')
                            r[id].d='E';
                        else if(r[id].d=='E')
                            r[id].d='N';
                    }
                    else if(orz=='R')
                    {
                        if(r[id].d=='N')
                            r[id].d='E';
                        else if(r[id].d=='E')
                            r[id].d='S';
                        else if(r[id].d=='S')
                            r[id].d='W';
                        else if(r[id].d=='W')
                            r[id].d='N';
                    }
                    else
                    {
                        ma[r[id].x][r[id].y]=0;
                        if(r[id].d=='S')
                            r[id].y--;
                        else if(r[id].d=='N')
                            r[id].y++;
                        else if(r[id].d=='E')
                            r[id].x++;
                        else
                            r[id].x--;
                        if(ma[r[id].x][r[id].y])
                        {
                            printf("Robot %d crashes into robot %d\n",id,ma[r[id].x][r[id].y]);
                            flag=0;
                            break;
                        }
                        else if(!r[id].x||!r[id].y||r[id].x==(a+1)||r[id].y==(b+1))
                        {
                            printf("Robot %d crashes into the wall\n",id);
                            flag=0;
                            break;
                        }
                        else
                            ma[r[id].x][r[id].y]=id;
                    }
                    if(!flag)
                        break;
                }
            }
        }
                    if(flag)
                        printf("OK\n");
    }
    return 0;
}

抱歉!评论已关闭.