现在的位置: 首页 > 综合 > 正文

UVa 1583 Digit Generator

2017年11月21日 ⁄ 综合 ⁄ 共 1224字 ⁄ 字号 评论关闭

For a positive integer N , the digit-sum of N is defined as the sum of N itself and its digits. When M is
the digitsum of N , we call N a generator of M .

For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.

Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.

You are to write a program to find the smallest generator of the given integer.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases Tis given in the first line of the
input. Each test case takes one line containing an integer N , 1$ \le$N$ \le$100,
000
 .

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has
multiple generators, print the smallest. If N does not have any generators, print 0.

The following shows sample input and output for three test cases.

Sample Input 

3 
216 
121 
2005

Sample Output 

198 
0 
1979
#include<stdio.h>
#include<string.h> 
#define maxn 100005
int ans[maxn];
int main(void)
{
	//freopen("input.txt","r",stdin);
	int T, n;
	memset(ans, 0, sizeof(ans));
	for(int m = 1; m < maxn; m++) {
		int x = m, y = m;
		while(x > 0) {
			y += x%10;
			x /= 10;
		}
		if(ans[y] == 0 || m < ans[y])
		ans[y] = m;
	} 
	scanf("%d", &T);
	while(T--) {
		scanf("%d", &n);
		printf("%d\n", ans[n]);
	}
	return 0;
} 

抱歉!评论已关闭.