现在的位置: 首页 > 综合 > 正文

POJ 3253 Fence Repair

2017年11月21日 ⁄ 综合 ⁄ 共 2087字 ⁄ 字号 评论关闭
Fence Repair
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 24153   Accepted: 7703

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤
50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengthsLi). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made;
you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the Nplanks. FJ knows that he can cut the board in various different orders which will
result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into
16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

Source

思路:哈弗曼树,这里巧用STL中的multiset,因为multiset中的数是自动按由小到大排序的!
AC代码:
#include<iostream>
#include<set>
using namespace std; 
int main()
{
  long long n,m,i,sum,w,p1,q1;
multiset<long> my;
multiset<long>::iterator p,q;
        cin>>m;sum=0;
	for(i=0;i<m;i++)
	{
	   cin>>w;
	   my.insert(w);//自动按照从小到大排序
	}
	while(1)
	{
	   p=my.begin();
	   p1=*p;
	   my.erase(p);
	   q=my.begin();
	   q1=*q;
	   my.erase(q);
	   sum+=p1+q1;
	   if(my.empty())
		   break;
	   my.insert(p1+q1);

	}
	cout<<sum<<endl;
  //system("pause");
  return 0;
}

抱歉!评论已关闭.