现在的位置: 首页 > 综合 > 正文

HDU 1914 The Stable Marriage Problem 稳定婚姻问题

2017年11月22日 ⁄ 综合 ⁄ 共 2594字 ⁄ 字号 评论关闭

The Stable Marriage Problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 465    Accepted Submission(s): 236

Problem Description
The stable marriage problem consists of matching members of two different sets according to the member’s preferences for the other set’s members. The input for our problem consists of:
a set M of n males;
a set F of n females;
for each male and female we have a list of all the members of the opposite gender in order of preference (from the most preferable to the least).
A marriage is a one-to-one mapping between males and females. A marriage is called stable, if there is no pair (m, f) such that f ∈ F prefers m ∈ M to her current partner and m prefers f over his current partner. The stable marriage A is called male-optimal
if there is no other stable marriage B, where any male matches a female he prefers more than the one assigned in A.

Given preferable lists of males and females, you must find the male-optimal stable marriage.

Input
The first line gives you the number of tests. The first line of each test case contains integer n (0 < n < 27). Next line describes n male and n female names. Male name is a lowercase letter, female name is an upper-case letter. Then
go n lines, that describe preferable lists for males. Next n lines describe preferable lists for females.

Output
For each test case find and print the pairs of the stable marriage, which is male-optimal. The pairs in each test case must be printed in lexicographical order of their male names as shown in sample output. Output an empty line between
test cases.

Sample Input
2 3 a b c A B C a:BAC b:BAC c:ACB A:acb B:bac C:cab 3 a b c A B C a:ABC b:ABC c:BCA A:bac B:acb C:abc
Sample Output
a A b B c C a B b A c C
/*
HDU 1914 稳定婚姻问题 
*/
#include<iostream>
#include<stdio.h>
#include<string>
#include<map>
#include<queue>
using namespace std;
#define N 27
char s[N][N];
int b[N][N],g[N][N],hash[N];
int bM[N],gM[N],rank[N];
int n;
queue<int>q;

int main()
{
	char str[N];
	int T,t1,t2,i,j,flag,t;
	
//	freopen("test.txt","r",stdin);
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		memset(bM,0,sizeof(bM));//配对 
		memset(gM,0,sizeof(gM));
		memset(hash,0,sizeof(hash));
		
		for(i=1;i<=n;i++)
		{
			scanf("%s",str);
			hash[str[0]-'a'+1]=1;//标记男生 
		} 
			
		for(i=1;i<=n;i++)
			scanf("%s",str);
			
		for(i=1;i<=n;i++)
		{
			scanf("%s",s[i]);
			t=s[i][0]-'a'+1; //男生 
			for(j=1;j<=n;j++)
			{
				b[t][j]=s[i][j+1]-'A'+1;//男生喜欢的女生排序 
			}
			rank[t]=1;//男生从第1个女生(最喜欢的)开始挑选 
			bM[t]=0;//男生还未匹配任何女生 
			q.push(t);//男生入队 
		}
		
		for(i=1;i<=n;i++)
		{
			scanf("%s",s[i]);
			t=s[i][0]-'A'+1;//女生 
			for(j=1;j<=n;j++)
			{
				g[t][s[i][j+1]-'a'+1]=j;//女生喜欢的男生排名 
			}
			gM[t]=0;//女生未匹配男生 
		}
		while(!q.empty())
		{
			i=q.front();//i表示男生 
			q.pop();
			
			t=b[i][rank[i]++];//按顺序挑选女生 
			if(!gM[t])//女生没有男朋友 
			{
				gM[t]=i;
				bM[i]=t;
			}
			else if(g[t][i]<g[t][gM[t]])//女生有男朋友,但是更喜欢i 
			{
				bM[gM[t]]=0;//该男生自由 
				q.push(gM[t]);//入队 
				gM[t]=i;
				bM[i]=t;
			}
			else
				q.push(i);	
		}
	
		for(i=1;i<=26;i++)
		{	
			if(hash[i])//按字母顺序输出,hash[i]=1表示男生 
				printf("%c %c\n",i-1+'a',bM[i]-1+'A');
		}
		if(T!=0)	
			printf("\n");
	}
	return 0;
} 

抱歉!评论已关闭.