现在的位置: 首页 > 综合 > 正文

HDU 1551 Cable master 二分

2017年11月22日 ⁄ 综合 ⁄ 共 2514字 ⁄ 字号 评论关闭

Cable master

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1902    Accepted Submission(s): 708

Problem Description
Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants
using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants
as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter, and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not
known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The input consists of several testcases. The first line of each testcase contains two integer numbers N and K, separated by a space. N (1 ≤ N ≤ 10000) is the number of cables in the stock, and K (1 ≤ K ≤ 10000) is the number of requested
pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 centimeter and at most 100 kilometers in length. All lengths in the input are written with a centimeter
precision, with exactly two digits after a decimal point.
The input is ended by line containing two 0's.
Output
For each testcase write to the output the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pi
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output must contain the single number "0.00" (without quotes).
Sample Input
4 11 8.02 7.43 4.57 5.39 0 0
Sample Output
2.00
/*
hdoj 1551 二分题目 思路同1969
就是找最大的 然后进行二分 判断个数是否符合要求 
*/

#include<iostream>
#include<stdio.h>
using namespace std;

int n,k;
double a[10001];
int sum(double x)
{
    int i,s=0;
    for(i=0;i<n;i++)
        s+=int(a[i]/x);
    if(s>=k) 
        return 1;
    else 
        return 0;
    
}
int main()
{
    double low,up,max,mid;
    int i;
    while(scanf("%d%d",&n,&k))
    {
        if(n==0&&k==0) break;
        max=0;
        for(i=0;i<n;i++)
        {
            scanf("%lf",&a[i]);
            if(max<a[i]) max=a[i];    
        }
        low=0;up=max;
        while(up-low>1e-5)
        {
            mid=(up+low)/2;
            if(sum(mid)==1)
                low=mid;
            else
                up=mid;
        }
        printf("%.2lf\n",(up+low)/2);        
    }
    return 0;
} 

抱歉!评论已关闭.