现在的位置: 首页 > 综合 > 正文

HDU 2052 Picture 绘图矩阵

2017年11月22日 ⁄ 综合 ⁄ 共 820字 ⁄ 字号 评论关闭

Picture

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16842    Accepted Submission(s): 8699


Problem Description
Give you the width and height of the rectangle,darw it.
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+ | | | | +---+
/*
HDU 2052 绘图矩阵 
*/
#include<iostream>
#include<stdio.h>
using namespace std;

int main()
{
	int n,m,i,j;
	
	
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=1;i<=m+2;i++)
		{
			if(i==1||i==m+2)
			{
				for(j=1;j<=n+2;j++)
				{
					if(j==1||j==n+2)
						printf("+");
					else
						printf("-");
				}
			}
			else
			{
				for(j=1;j<=n+2;j++)
				{
					if(j==1||j==n+2)
							printf("|");
						else
							printf(" ");	
				}
			}	
			printf("\n");
		}	
		printf("\n");
	}
	return 0;
}

抱歉!评论已关闭.