现在的位置: 首页 > 综合 > 正文

HDU 5055 Bob and math problem 数学题

2017年11月22日 ⁄ 综合 ⁄ 共 1557字 ⁄ 字号 评论关闭

Bob and math problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1092    Accepted Submission(s): 411

Problem Description
Recently, Bob has been thinking about a math problem.
There are N Digits, each digit is between 0 and 9. You need to use this N Digits to constitute an Integer.
This Integer needs to satisfy the following conditions:
  • 1. must be an odd Integer.
  • 2. there is no leading zero.
  • 3. find the biggest one which is satisfied 1, 2.

Example:
There are three Digits: 0, 1, 3. It can constitute six number of Integers. Only "301", "103" is legal, while "130", "310", "013", "031" is illegal. The biggest one of odd Integer is "301".

Input
There are multiple test cases. Please process till EOF.
Each case starts with a line containing an integer N ( 1 <= N <= 100 ).
The second line contains N Digits which indicate the digit
a1,a2,a3,,an.(0ai9).
Output
The output of each test case of a line. If you can constitute an Integer which is satisfied above conditions, please output the biggest one. Otherwise, output "-1" instead.
Sample Input
3 0 1 3 3 5 4 2 3 2 4 6
Sample Output
301 425 -1
/*
HDU 5055 数学题 
主要注意几点:
1、n=1的情况, 
2、没有奇数 -1 
3、n>1时,只有一个奇数,其他都为0  -1 
*/
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define N 101
int a[N];
int main()
{
	int n,i,oddNum,num,min;
	while(scanf("%d",&n)!=EOF)
	{
		oddNum=0;//奇数个数 
		num=0;//非0的个数 
		
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			if(a[i]&1)
				oddNum++;
			if(a[i]!=0)
				num++;
		}
		if(n==1)//n==1的判断 
		{
			if(a[0]&1)
				printf("%d\n",a[0]);
			else
				printf("-1\n");
			continue;
		}	
				
		if(oddNum<1||(oddNum==1&&num==1))
		{
			printf("-1\n");
			continue;
		}
		sort(a,a+n);//从小到大 
		for(i=0;i<n;i++)
			if(a[i]&1)//寻找最小的一个奇数放在最后 
			{
				min=i;
				break;
			} 
		for(i=n-1;i>=0;i--)
		{
			if(i!=min)
				printf("%d",a[i]);
		}
		printf("%d\n",a[min]);
	}
	return 0;
} 

抱歉!评论已关闭.