现在的位置: 首页 > 综合 > 正文

HDU 3339 In Action 最短路+01背包

2017年11月22日 ⁄ 综合 ⁄ 共 2706字 ⁄ 字号 评论关闭

In Action

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4204    Accepted Submission(s): 1353

Problem Description

Since 1945, when the first nuclear bomb was exploded by the Manhattan Project team in the US, the number of nuclear weapons have soared across the globe.
Nowadays,the crazy boy in FZU named AekdyCoin possesses some nuclear weapons and wanna destroy our world. Fortunately, our mysterious spy-net has gotten his plan. Now, we need to stop it.
But the arduous task is obviously not easy. First of all, we know that the operating system of the nuclear weapon consists of some connected electric stations, which forms a huge and complex electric network. Every electric station has its power value. To start
the nuclear weapon, it must cost half of the electric network's power. So first of all, we need to make more than half of the power diasbled. Our tanks are ready for our action in the base(ID is 0), and we must drive them on the road. As for a electric station,
we control them if and only if our tanks stop there. 1 unit distance costs 1 unit oil. And we have enough tanks to use.
Now our commander wants to know the minimal oil cost in this action.
 

Input
The first line of the input contains a single integer T, specifying the number of testcase in the file.
For each case, first line is the integer n(1<= n<= 100), m(1<= m<= 10000), specifying the number of the stations(the IDs are 1,2,3...n), and the number of the roads between the station(bi-direction).
Then m lines follow, each line is interger st(0<= st<= n), ed(0<= ed<= n), dis(0<= dis<= 100), specifying the start point, end point, and the distance between.
Then n lines follow, each line is a interger pow(1<= pow<= 100), specifying the electric station's power by ID order.
 

Output
The minimal oil cost in this action.
If not exist print "impossible"(without quotes).
 

Sample Input
2 2 3 0 2 9 2 1 3 1 0 2 1 3 2 1 2 1 3 1 3
 

Sample Output
5 impossible
/*
HDOJ 3339 最短路+01背包 

*/
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define N 101
#define INF 99999999

struct node{
    int val,price;
};

node e[N];
int map[N][N],dp[100001];
int n,m;

void floyd()
{
    int i,j,k;
    for(k=0;k<=n;k++)
        for(i=0;i<=n;i++)
        {
            if(map[i][k]!=INF)
            {
                for(j=0;j<=n;j++)
                if(map[i][k]+map[k][j]<map[i][j])
                    map[i][j]=map[i][k]+map[k][j];
            }
        }
}
 

int main()
{
    int t,i,j,a,b,k,sum,total;
    
//    freopen("test.txt","r",stdin);
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<=n;i++)
            for(j=0;j<=n;j++)
                map[i][j]=INF;
                
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&a,&b,&k);
            map[a][b]=map[b][a]=map[a][b]<k?map[a][b]:k; 
        }
    
        floyd();
        
        sum=0;total=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&e[i].val);//pow看作为价值 
            sum+=e[i].val;
            e[i].price=map[0][i];
            if(e[i].price!=INF)
                total+=e[i].price;//路径大小 钱的总数 
        }
        
        memset(dp,0,sizeof(dp)); 
        //用最少的钱 获得最大的价值
        for(i=1;i<=n;i++)
        {
            if(e[i].price==INF)
                continue;
            for(j=total;j>=e[i].price;j--)
                if(dp[j]<(dp[j-e[i].price]+e[i].val))
                    dp[j]=dp[j-e[i].price]+e[i].val;
        }
        
        sum=sum/2+1;
        for(i=0;i<=total;i++)//total总的路径 
            if(dp[i]>=sum)
                break;
        if(i>total)
            printf("impossible\n");
        else
            printf("%d\n",i);
    }
    return 0;
} 

抱歉!评论已关闭.