现在的位置: 首页 > 综合 > 正文

HDU 3496 Watch The Movie 二维背包

2017年11月22日 ⁄ 综合 ⁄ 共 2160字 ⁄ 字号 评论关闭

Watch The Movie

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 5163    Accepted Submission(s): 1637

Problem Description
New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight.
Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play
over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they
cost not more then L.
How clever you are! Please help DuoDuo’s uncle.
Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy.
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
Output
Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
Sample Input
1 3 2 10 11 100 1 2 9 1
Sample Output
3
/*
HDU 3496 背包问题 dp
二维背包
dp[j][k]表示时间为j内, 看k张碟子得到的最大价值。
dp[j][k] = max(dp[j][k], dp[j-w[i]][k-1]+v[i])
*/

#include<iostream>
#include<cstring>
using namespace std;
int dp[1002][101];
int main(){
    
    int c,n,m,i,j,k,l,v[101],w[101];
    
    cin>>c;
    while(c--)
    {
        scanf("%d%d%d",&n,&m,&l);
    
        for(i=0;i<n;i++)
            scanf("%d%d",&w[i],&v[i]);//时间 价值 
            
        //memset(dp,0,sizeof(dp));    
        for(i=0;i<=l;i++)
            for(j=0;j<=m;j++)
            {
                dp[i][j]=-1;
                if(j==0) dp[i][j]=0;
            }
        
        for(i=0;i<n;i++)         
            for(j=l;j>=w[i];j--)     
                for(k=m;k>0;k--) //碟子数 
                    if(dp[j-w[i]][k-1]!=-1&&dp[j][k]<dp[j-w[i]][k-1]+v[i])
                        dp[j][k]=dp[j-w[i]][k-1]+v[i];
        if(dp[l][m] == -1)  
            printf("0\n");  
        else  
        printf("%d\n",dp[l][m]);
    }
    return 0;
} 

抱歉!评论已关闭.