现在的位置: 首页 > 综合 > 正文

HDU 1171 Big Event in HDU 背包

2017年11月22日 ⁄ 综合 ⁄ 共 2031字 ⁄ 字号 评论关闭

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22348    Accepted Submission(s): 7843

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that
A is not less than B.
Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
Sample Output
20 10 40 40
/*
多重背包的应用
可以看背包九讲
01背包:
void bag01(int cost,int weight)
{
 for(i=v;i>=cost;i--)
  if(dp[i]<dp[i-cost]+weight)
   dp[i]=dp[i-cost]+weight;
}
完全背包:
void complete(int cost,int weight)
{
 for(i=cost;i<=v;i++)
  if(dp[i]<dp[i-cost]+weight)
   dp[i]=dp[i-cost]+weight;
}
多重背包:
void multiply(int cost,int weight,int amount)
{
 if(cost*amount>=v)
  complete(cost,weight);
 else{
  k=1;
  while(k<amount){
   bag01(k*cost,k*weight);
   amount-=k;
   k+=k;
  }
  bag01(cost*amount,weight*amount);
 }
}
*/
#include<iostream>
#include<cstring>
using namespace std;
int dp[250001]; //总的是250000 

int main(){
    
    int v[55],m[55],i,j,n,k,vol,sum;
    
    while(cin>>n&&n>=0)    
    {
        
        sum=0;
        for(i=0;i<n;i++)
            {
                scanf("%d%d",&v[i],&m[i]);
                sum+=v[i]*m[i];    
            }
        vol=sum/2;
        memset(dp,0,sizeof(dp)); 
        
        for(i=0;i<n;i++) 
            for(j=0;j<m[i];j++)  //物品多少个 执行多少次 
                for(k=vol;k>=v[i];k--) 
                    if(dp[k]<dp[k-v[i]]+v[i])
                        dp[k]=dp[k-v[i]]+v[i];
    
        printf("%d %d\n",sum-dp[vol],dp[vol]);
    }    
    return 0;
}

抱歉!评论已关闭.