现在的位置: 首页 > 综合 > 正文

HIT OJ 1069 哈工大

2017年11月22日 ⁄ 综合 ⁄ 共 2812字 ⁄ 字号 评论关闭

 

Prime Land

  Source : ACM ICPC Central European Regional 1997
  Time limit : 1 sec   Memory limit : 32 M

Submitted : 238, Accepted : 133

Everybody in the Prime Land is using a prime base number system. In this system, each positive integer x is represented as follows: Let {pi}i=0 denote the increasing sequence of all prime numbers. We know that x > 1 can be represented in only one way in
the form of product of powers of prime factors. This implies that there is an integer kx and uniquely determined integers ekx, ekx-1, ..., e1, e0, (ekx > 0), that x = p(ekx,kx)*p(ekx-1,kx-1)*...*p(e1,1)*p(e0,0). The sequence

(ekx, ekx-1, ... ,e1, e0)

is considered to be the representation of x in prime base number system.

It is really true that all numerical calculations in prime base number system can seem to us a little bit unusual, or even hard. In fact, the children in Prime Land learn to add to subtract numbers several years. On the other hand, multiplication and division
is very simple.

Recently, somebody has returned from a holiday in the Computer Land where small smart things called computers have been used. It has turned out that they could be used to make addition and subtraction in prime base number system much easier. It has been
decided to make an experiment and let a computer to do the operation ``minus one''.

Help people in the Prime Land and write a corresponding program.

For practical reasons we will write here the prime base representation as a sequence of such pi and ei from the prime base representation above for which ei > 0. We will keep decreasing order with regard to pi.

Input

The input consists of lines (at least one) each of which except the last contains prime base representation of just one positive integer greater than 2 and less or equal 32767. All numbers in the line are separated by one space. The last line contains number
0.

Output

The output contains one line for each but the last line of the input. If x is a positive integer contained in a line of the input, the line in the output will contain x - 1 in prime base representation. All numbers in the line are separated by one space. There
is no line in the output corresponding to the last ``null'' line of the input.

Sample Input

17 1
5 1 2 1
509 1 59 1
0

Sample Output

2 4
3 2
13 1 11 1 7 1 5 1 3 1 2 1

 
 
题目意思就是给你x的质因数分解,然后求x-1的质因数分解,入门题目~
 
 
我的代码:
#include<stdio.h>
#include<algorithm>
#include<string.h>

using namespace std;

struct node
{
	int p;
	int e;
};
node k[100];
bool flag[205];
int prime[205];

void init()
{
	int i,j,num=0;
	for(i=2;i<=200;i++)
	{
		if(!flag[i])
		{
			prime[num++]=i;
			for(j=i*i;j<=200;j=j+i)
				flag[j]=true;
		}
	}
}

void solve(int n)
{
	int i,num=0;
	for(i=0;prime[i]*prime[i]<=n;i++)
	{
		if(n%prime[i]==0)
		{
			n=n/prime[i];
			k[num].p=prime[i];
			k[num].e=1;
			while(n%prime[i]==0)
			{
				n=n/prime[i];
				k[num].e=k[num].e+1;
			}
			num++;
		}
		if(n==1)
			break;
	}
	if(n>1)
	{
		k[num].e=1;
		k[num].p=n;
		num++;
	}
	for(i=num-1;i>0;i--)
		printf("%d %d ",k[i].p,k[i].e);
	printf("%d %d\n",k[0].p,k[0].e);
}

int main()
{
	init();
	int n,num,a,b,i,j,cop;
	char x;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
			break;
		num=0;
		k[num].p=n;
		scanf("%d",&a);
		k[num].e=a;
		num++,cop=1;
		while(true)
		{
			scanf("%c",&x);
			if(x=='\n')
				break;
			scanf("%d %d",&a,&b);
			k[num].p=a;
			k[num].e=b;
			num++;
		}
		for(i=0;i<num;i++)
		{
			for(j=1;j<=k[i].e;j++)
				cop=cop*k[i].p;
		}
	//	printf("%d\n",cop);
		solve(cop-1);
	}
	return 0;
}

抱歉!评论已关闭.