现在的位置: 首页 > 综合 > 正文

POJ 3298 递推,DP

2017年11月22日 ⁄ 综合 ⁄ 共 1414字 ⁄ 字号 评论关闭
Antimonotonicity
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 2428   Accepted: 995

Description

I have a sequence Fred of length n comprised of integers between 1 and n inclusive. The elements of Fred are pairwise distinct. I want to find a subsequence Mary of Fred that is as long as possible and has the property that:

Mary0 > Mary1 < Mary2 > Mary3 < ...

Input

The first line of input will contain a single integer T expressed in decimal with no leading zeroes. T will be at most 50. T test cases will follow.

Each test case is contained on a single line. A line describing a test case is formatted as follows:

n Fred0Fred1Fred2 ... Fredn-1.

where n and each element of Fred is an integer expressed in decimal with no leading zeroes. No line will have leading or trailing whitespace, and two adjacent integers on the same line will be separated by a single space. n will be at most 30000.

Output

For each test case, output a single integer followed by a newline --- the length of the longest subsequence Mary of Fred with the desired properties.

Sample Input

4
5 1 2 3 4 5
5 5 4 3 2 1
5 5 1 4 2 3
5 2 4 1 3 5

Sample Output

1
2
5
3

Source

利用凹凸函数,依次递推。。

Source Code

Problem: 3298   User: bingshen
Memory: 252K   Time: 172MS
Language: C++   Result: Accepted
  • Source Code

    #include<stdio.h>
    #include<string.h>
    
    int a[30005];
    
    int main()
    {
    	int i,t,n,m,ans;
    	bool s;
    	scanf("%d",&t);
    	while(t--)
    	{
    		ans=1;
    		scanf("%d",&n);
    		for(i=1;i<=n;i++)
    			scanf("%d",&a[i]);
    		m=a[1];
    		s=true;
    		for(i=2;i<=n;i++)
    		{
    			if(m<a[i]&&s)
    				m=a[i];
    			else if(m>a[i]&&!s)
    				m=a[i];
    			else if(m>a[i]&&s)
    			{
    				m=a[i];
    				s=false;
    				ans++;
    			}
    			else if(m<a[i]&&!s)
    			{
    				m=a[i];
    				s=true;
    				ans++;
    			}
    		}
    		printf("%d/n",ans);
    	}
    	return 0;
    }
    

抱歉!评论已关闭.