现在的位置: 首页 > 综合 > 正文

POJ 2409 波利亚原理

2017年11月23日 ⁄ 综合 ⁄ 共 2003字 ⁄ 字号 评论关闭

 

Let it Bead
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2671   Accepted: 1702

Description

"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets.
However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not
be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced.

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate
the number of different bracelets that can be made.

Input

Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical
difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.

Output

For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.

Sample Input

1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0

Sample Output

1
2
3
5
8
13
21

Source

 
 
方法和上一篇博文(POJ 2154)是一样的。我同样使用了欧拉函数进行优化求解,虽然此题没有必要。
 
我的代码:
#include<stdio.h>
#include<string.h>

typedef int ll;

ll eular(ll n)
{
	ll ret=1,i;
	for(i=2;i*i<=n;i++)
	{
		if(n%i==0)
		{
			ret=ret*(i-1);
			n=n/i;
			while(n%i==0)
			{
				n=n/i;
				ret=ret*i;
			}
		}
		if(n==1)
			break;
	}
	if(n>1)
		ret=ret*(n-1);
	return ret;
}

ll exmod(ll a,ll b)
{
	int ret=1,i;
	for(i=1;i<=b;i++)
		ret=ret*a;
	return ret;
}

int main()
{
	ll n,ans,i,m;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		if(n==0&&m==0)
			break;
		ans=0;
		for(i=1;i*i<n;i++)
		{
			if(n%i==0)
			{
				ans=ans+eular(n/i)*exmod(m,i);
				ans=ans+eular(i)*exmod(m,n/i);
			}
		}
		if(i*i==n)
			ans=ans+eular(n/i)*exmod(m,i);
		if(n&1)
			ans=ans+exmod(m,n/2+1)*n;
		else
			ans=ans+exmod(m,n/2)*n/2+exmod(m,n/2+1)*n/2;
		printf("%d\n",ans/n/2);
	}
	return 0;
}

抱歉!评论已关闭.