现在的位置: 首页 > 综合 > 正文

POJ 1789 最小生成树问题

2017年11月23日 ⁄ 综合 ⁄ 共 2952字 ⁄ 字号 评论关闭
Truck History
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8416   Accepted: 3027

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)
where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

 

题目要求距离最小,所以生成的图中有环的存在,则一定可以去掉一条边把距离变得更小,所以最后连接完了的图形,一定是一棵树。。(1)

所以题目转化为求一棵树,且让这棵树的距离之和最小,很显然的最小生成树题目。。(2)

 

中途居然把prim的实现搞忘了。。很囧。。

my ugly code:

Source Code

Problem: 1789   User: bingshen
Memory: 15648K   Time: 360MS
Language: C++   Result: Accepted
  • Source Code

    #include<stdio.h>
    #include<algorithm>
    #include<string.h>
    #define inf 99999999
    
    using namespace std;
    
    struct node
    {
    	int v1;
    	int v2;
    	int dis;
    };
    node e[2005];
    int dis[2005][2005];
    char truck[2005][10];
    
    int dist(int a,int b)
    {
    	int i,sum=0;
    	for(i=0;i<7;i++)
    	{
    		if(truck[a][i]!=truck[b][i])
    			sum++;
    	}
    	return sum;
    }
    
    int prim(int n)
    {
    	int i,j,min,minl,vx,vy,leng;
    	int res=0;
    	for(i=1;i<=n-1;i++)
    	{
    		e[i].v1=1;
    		e[i].v2=i+1;
    		e[i].dis=dis[1][i+1];
    	}
    	for(i=1;i<=n-1;i++)
    	{
    		minl=inf;
    		min=-1;
    		for(j=i;j<=n-1;j++)
    		{
    			if(minl>e[j].dis)
    			{
    				minl=e[j].dis;
    				min=j;
    			}
    		}
    		if(min==-1)
    			break;
    		res=res+minl;
    		swap(e[i],e[min]);
    		vx=e[i].v2;
    		for(j=i+1;j<=n-1;j++)
    		{
    			vy=e[j].v2;
    			leng=dis[vx][vy];
    			if(leng<e[j].dis)
    			{
    				e[j].dis=leng;
    				e[j].v1=vx;
    			}
    		}
    	}
    	return res;
    }
    
    int main()
    {
    	int i,j,n,ans;
    	scanf("%d",&n);
    	while(scanf("%d",&n)!=EOF)
    	{
    		if(n==0)
    			break;
    		for(i=1;i<=n;i++)
    			scanf("%s",truck[i]);
    		for(i=1;i<=n;i++)
    			for(j=1;j<=n;j++)
    				dis[i][j]=dist(i,j);
    		ans=prim(n);
    		printf("The highest possible quality is 1/%d./n",ans);
    	}
    	return 0;
    }

抱歉!评论已关闭.