现在的位置: 首页 > 综合 > 正文

POJ 1486 二分图的最大匹配(强化)

2017年11月23日 ⁄ 综合 ⁄ 共 3221字 ⁄ 字号 评论关闭
Sorting Slides
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 1801   Accepted: 648

Description

Professor Clumsey is going to give an important talk this afternoon. Unfortunately, he is not a very tidy person and has put all his transparencies on one big heap. Before giving the talk, he has to sort the slides. Being a kind of minimalist, he wants to do this with the minimum amount of work possible.

The situation is like this. The slides all have numbers written on them according to their order in the talk. Since the slides lie on each other and are transparent, one cannot see on which slide each number is written.

Well, one cannot see on which slide a number is written, but one may deduce which numbers are written on which slides. If we label the slides which characters A, B, C, ... as in the figure above, it is obvious that D has number 3, B has number 1, C number 2 and A number 4.

Your task, should you choose to accept it, is to write a program that automates this process.

Input

The input consists of several heap descriptions. Each heap descriptions starts with a line containing a single integer n, the number of slides in the heap. The following n lines contain four integers xmin, xmax, ymin and ymax, each, the bounding coordinates of the slides. The slides will be labeled as A, B, C, ... in the order of the input.

This is followed by n lines containing two integers each, the x- and y-coordinates of the n numbers printed on the slides. The first coordinate pair will be for number 1, the next pair for 2, etc. No number will lie on a slide boundary.

The input is terminated by a heap description starting with n = 0, which should not be processed.

Output

For each heap description in the input first output its number. Then print a series of all the slides whose numbers can be uniquely determined from the input. Order the pairs by their letter identifier.

If no matchings can be determined from the input, just print the word none on a line by itself.

Output a blank line after each test case.

Sample Input

4
6 22 10 20
4 18 6 16
8 20 2 18
10 24 4 8
9 15
19 17
11 7
21 11
2
0 2 0 2
0 2 0 2
1 1
1 1
0

Sample Output

Heap 1
(A,4) (B,1) (C,2) (D,3)

Heap 2
none

Source

Source Code

Problem: 1486   User: bingshen
Memory: 176K   Time: 0MS
Language: C++   Result: Accepted
  • Source Code

    #include<stdio.h>
    #include<algorithm>
    #include<string.h>
    
    using namespace std;
    
    struct Rect
    {
    	int minx;
    	int maxx;
    	int miny;
    	int maxy;
    };
    struct Point
    {
    	int x;
    	int y;
    };
    
    Rect rect[200];
    Point point[200];
    bool map[200][200];
    int link[200];
    bool used[200];
    int n;
    
    bool judge(Rect a,Point b)
    {
    	if(a.minx<=b.x&&b.x<=a.maxx&&a.miny<=b.y&&b.y<=a.maxy)
    		return true;
    	else
    		return false;
    }
    
    bool dfs(int v)
    {
    	int i;
    	for(i=1;i<=n;i++)
    	{
    		if(!used[i]&&map[v][i])
    		{
    			used[i]=true;
    			if(link[i]==-1||dfs(link[i]))
    			{
    				link[i]=v;
    				return true;
    			}
    		}
    	}
    	return false;
    }
    
    bool mark()
    {
    	int i;
    	memset(link,-1,sizeof(link));
    	for(i=1;i<=n;i++)
    	{
    		memset(used,0,sizeof(used));
    		if(!dfs(i))
    			return false;
    	}
    	return true;
    }
    
    int main()
    {
    	int i,j,t=1,k;
    	while(scanf("%d",&n)!=EOF)
    	{
    		if(n==0)
    			break;
    		memset(map,0,sizeof(map));
    		for(i=1;i<=n;i++)
    			scanf("%d%d%d%d",&rect[i].minx,&rect[i].maxx,&rect[i].miny,&rect[i].maxy);
    		for(i=1;i<=n;i++)
    			scanf("%d%d",&point[i].x,&point[i].y);
    		for(i=1;i<=n;i++)
    			for(j=1;j<=n;j++)
    			{
    				if(judge(rect[i],point[j]))
    					map[i][j]=true;
    			}
    		bool first=false;
    		printf("Heap %d/n",t++);
    		for(i=1;i<=n;i++)
    			for(j=1;j<=n;j++)
    			{
    				if(map[i][j]==true)
    				{
    					map[i][j]=false;
    					if(!mark())
    					{
    						if(!first)
    						{
    							printf("(%c,%d)",i+'A'-1,j);
    							first=true;
    						}
    						else
    							printf(" (%c,%d)",i+'A'-1,j);
    						for(k=1;k<=n;k++)
    						{
    							if(k!=i)
    								map[k][j]=false;
    							if(k!=j)
    								map[i][k]=false;
    						}
    					}
    					map[i][j]=true;
    				}
    			}
    		if(!first)
    			printf("none/n/n");
    		else
    			printf("/n/n");
    	}
    	return 0;
    }
    
顺便说一下,单纯的用贪心貌似是有问题的,只是数据不严格可能也会AC,但是按道理有些特殊的数据是过不了的。。

抱歉!评论已关闭.