现在的位置: 首页 > 综合 > 正文

HDOJ 5131 Song Jiang’s rank list 水

2017年11月23日 ⁄ 综合 ⁄ 共 3025字 ⁄ 字号 评论关闭

水排序

Song Jiang's rank list

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 71    Accepted Submission(s): 39


Problem Description
《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai'an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from different backgrounds (including
scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader.

In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two
outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.

 


Input
There are no more than 20 test cases.

For each test case:

The first line is an integer N (0<N<200), indicating that there are N outlaws.

Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique. 

The next line is an integer M (0<M<200) ,indicating that there are M queries.

Then M queries follow. Each query is a line containing an outlaw's name. 
The input ends with n = 0

 


Output
For each test case, print the rank list first. For this part in the output ,each line contains an outlaw's name and the number of enemies he killed. 

Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws
who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed
that each query has an answer for it.

 


Sample Input
5 WuSong 12 LuZhishen 12 SongJiang 13 LuJunyi 1 HuaRong 15 5 WuSong LuJunyi LuZhishen HuaRong SongJiang 0
 


Sample Output
HuaRong 15 SongJiang 13 LuZhishen 12 WuSong 12 LuJunyi 1 3 2 5 3 1 2
 


Source
 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <map>

using namespace std;

const int maxn=222;

int n,m;
struct HERO
{
    string name;
    int kill;
}hero[maxn];

map<string,int> msi;

bool cmp(HERO a,HERO b)
{
    if(a.kill!=b.kill)
        return a.kill>b.kill;
    return a.name<b.name;
}

int kaka[maxn],kn;

int main()
{
    while(scanf("%d",&n)!=EOF&&n)
    {
        kn=0;
        for(int i=0;i<n;i++)
        {
            cin>>hero[i].name>>hero[i].kill;
            kaka[kn++]=hero[i].kill;
        }
        sort(kaka,kaka+kn);
        sort(hero,hero+n,cmp);
        msi.clear();
        for(int i=0;i<n;i++)
        {
            msi[hero[i].name]=i;
            cout<<hero[i].name<<" "<<hero[i].kill<<endl;
        }
        scanf("%d",&m);
        while(m--)
        {
            string name;
            cin>>name;
            int id=msi[name];
            int major=n-(upper_bound(kaka,kaka+kn,hero[id].kill)-kaka)+1;
            /// check minor
            int minor=0;
            int ki=hero[id].kill;
            for(int j=id-1;j>=0;j--)
            {
                if(hero[j].kill==ki)
                {
                    minor++;
                }
            }
            if(minor==0)
            {
                printf("%d\n",major);
            }
            else
            {
                printf("%d %d\n",major,minor+1);
            }
        }
    }
    return 0;
}

抱歉!评论已关闭.