现在的位置: 首页 > 综合 > 正文

UVA 1025 A Spy in the Metro DP

2017年11月23日 ⁄ 综合 ⁄ 共 3957字 ⁄ 字号 评论关闭

DP[ i ][ j ] 在 i 时刻 j 号车站的等待最小时间.....

有3种可能: 在原地等,坐开往左边的车,做开往右边的车

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table.
The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated.

Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great
risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets
her to the last station in time for her appointment. You must write a program that finds the total waiting time in a best schedule for Maria.

The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station
to the last station and from the last station back to the first station. The time required for a train to travel between two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can
ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.

\epsfbox{p2728.eps}

Input 

The input file contains several test cases. Each test case consists of seven lines with information as follows.

Line 1.
The integer N ( 2$ \le$N$ \le$50),
which is the number of stations.
Line 2.
The integer T ( 0$ \le$T$ \le$200),
which is the time of the appointment.
Line 3.
N - 1 integers: t1t2,..., tN - 1 ( 1$ \le$ti$ \le$70),
representing the travel times for the trains between two consecutive stations: t1 represents the travel time between the first two stations, t2 the time between the
second and the third station, and so on.
Line 4.
The integer M1 ( 1$ \le$M1$ \le$50),
representing the number of trains departing from the first station.
Line 5.
M1 integers: d1d2,..., dM1 ( 0$ \le$di$ \le$250 and di < di
+ 1
), representing the times at which trains depart from the first station.
Line 6.
The integer M2 ( 1$ \le$M2$ \le$50),
representing the number of trains departing from the N-th station.
Line 7.
M2 integers: e1e2,..., eM2 ( 0$ \le$ei$ \le$250 and ei < ei
+ 1
) representing the times at which trains depart from the N-th station.

The last case is followed by a line containing a single zero.

Output 

For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word `impossible' in case Maria is unable to make the appointment. Use the
format of the sample output.

Sample Input 

4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
1 2 3
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17
0

Sample Output 

Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible

Source

Root :: ACM-ICPC World Finals :: 2003 - Beverly Hills

Root :: AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) :: Chapter 9. Dynamic Programming :: Examples

 Status

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int INF=0x3f3f3f3f;
const int maxn=440;

int n,T;
int t[maxn];
int m1,d1[maxn];
int m2,d2[maxn];
int dp[maxn][maxn];
bool hasR[maxn][maxn],hasL[maxn][maxn];

void init()
{
    memset(hasR,0,sizeof(hasR));
    memset(hasL,0,sizeof(hasL));
    memset(dp,63,sizeof(dp));
    memset(t,0,sizeof(t));
    memset(d1,0,sizeof(d1));
    memset(d2,0,sizeof(d2));
}

void getH()
{
    for(int i=0;i<m1;i++)
    {
        int time=d1[i];
        for(int j=1;j<=n;j++)
        {
            time+=t[j];
            hasR[time][j]=true;
        }
    }

    for(int i=0;i<m2;i++)
    {
        int time=d2[i];
        for(int j=n;j>=1;j--)
        {
            time+=t[j+1];
            hasL[time][j]=true;
        }
    }
}

int main()
{
    int cas=1;
    while(scanf("%d",&n)!=EOF&&n)
    {
        init();

        scanf("%d",&T);
        for(int i=2;i<=n;i++)
            scanf("%d",t+i);
        scanf("%d",&m1);
        for(int i=0;i<m1;i++)
            scanf("%d",d1+i);
        scanf("%d",&m2);
        for(int i=0;i<m2;i++)
            scanf("%d",d2+i);

        getH();

        dp[T][n]=0;

        for(int i=T-1;i>=0;i--)
        {
            for(int j=1;j<=n;j++)
            {
                dp[i][j]=dp[i+1][j]+1;

                if(j<n&&i+t[j+1]<=T&&hasR[i][j])
                    dp[i][j]=min(dp[i][j],dp[i+t[j+1]][j+1]);

                if(j>1&&i+t[j]<=T&&hasL[i][j])
                    dp[i][j]=min(dp[i][j],dp[i+t[j]][j-1]);
            }
        }

        printf("Case Number %d: ",cas++);
        if(dp[0][1]>=INF) puts("impossible");
        else printf("%d\n",dp[0][1]);
    }
    return 0;
}

抱歉!评论已关闭.