现在的位置: 首页 > 综合 > 正文

HDOJ 1711 Number Sequence

2017年11月23日 ⁄ 综合 ⁄ 共 2207字 ⁄ 字号 评论关闭

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8600    Accepted Submission(s): 3953


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b
(1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b
. If there are more than one K exist, output the smallest one.
 


Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b
. All integers are in the range of [-1000000, 1000000].
 


Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 


Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 


Sample Output
6
-1
 


Source
 


Recommend
lcy
 

 

没事水一把KMP。。。。。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int n,m;

int a[1000010],b[1000010],next[1000010];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(next,0,sizeof(next));
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%d",a+i);
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d",b+i);
        }
        for(int i=1;i<m;i++)
        {
            int j=i;
            while(j>0)
            {
                j=next[j];
                if(b==b[j])
                {
                    next[i+1]=j+1;
                    break;
                }
            }
        }
        int pos=-2;
        for(int i=0,j=0;i<n;i++)
        {
            if(j<m&&a==b[j])
            {
                j++;
            }
            else
            {
                while(j>0)
                {
                    j=next[j];
                    if(a==b[j])
                    {
                        j++;
                        break;
                    }
                }
            }
            if(j==m)
            {
                pos=i-m+1;
                break;
            }
        }
        printf("%d\n",pos+1);
    }
    return 0;
}

* This source code was highlighted by YcdoiT. ( style: Codeblocks )

抱歉!评论已关闭.