现在的位置: 首页 > 综合 > 正文

HDOJ 5095 Linearization of the kernel functions in SVM 坑题

2017年11月23日 ⁄ 综合 ⁄ 共 1907字 ⁄ 字号 评论关闭

水题+坑题:

0,-1,1,开头是正数。。。。

Linearization of the kernel functions in SVM

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 96    Accepted Submission(s): 71


Problem Description
SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z)
= ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2 <-> p, y^2 <-> q, z^2 <-> r,
xy <->u, yz <-> v, zx <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which
is a linear function with 9 variables.

Now your task is to write a program to change f into g.

 


Input
The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z)
= ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.
 


Output
For each input function, print its correspondent linear function with 9 variables in conventional way on one line.
 


Sample Input
2 0 46 3 4 -5 -22 -8 -32 24 27 2 31 -5 0 0 12 0 0 -49 12
 


Sample Output
46q+3r+4u-5v-22w-8x-32y+24z+27 2p+31q-5r+12w-49z+12
 


Source
 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int a[21],n;

char str[20]={'p','q','r','u','v','w','x','y','z'};

void OUT()
{
    bool ok=false;
    for(int i=0;i<9;i++)
    {
        if(a[i]==0) continue;
        if(a[i]>0&&ok) putchar('+');
        if(a[i]!=1&&a[i]!=-1)
        {
            printf("%d%c",a[i],str[i]);
        }
        else
        {
            if(a[i]==1)
            {
                 printf("%c",str[i]);
            }
            else printf("-%c",str[i]);
        }
        ok=true;
    }
    if(ok==true&&a[9]!=0)
    {
        if(a[9]>0) putchar('+');
        printf("%d",a[9]);
    }
    else if(ok==false) printf("%d",a[9]);
    putchar(10);
}

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        for(int i=0;i<10;i++)
            scanf("%d",a+i);
        OUT();
    }
    return 0;
}

抱歉!评论已关闭.