现在的位置: 首页 > 综合 > 正文

ZOJ 3829 Known Notation 乱搞

2017年11月23日 ⁄ 综合 ⁄ 共 2781字 ⁄ 字号 评论关闭

乱搞:

1.数字的个数要比*的个数多一个,如果数字不足需要先把数字补满

2.最优的结构应该是数字都在左边,*都在右边

3.从左往右扫一遍,遇到数字+1,遇到*-1,如果当前值<1则把这个*和最后面的一个数字交换位置

Known Notation


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression
follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there
are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix
expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence
which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations
to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2

Author: CHEN, Cong
Source: The 2014 ACM-ICPC Asia Mudanjiang Regional Contest

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

char str[2000];

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%s",str);
        int len=strlen(str);
        int c=0,start=0;
        bool flag=false;
        for(int i=0;i<len;i++)
        {
            if(str[i]=='*')
            {
                flag=true;
                c--;
                start++;
            }
            else c++;
        }
        int ans=0;
        if(c<=0) ans=start+1-(len-start);
        c=ans;
        for(int i=0;i<len;i++)
        {
            if(str[i]=='*') c--;
            else c++;
            if(c<1)
            {
                for(int j=len-1;j>i;j--)
                {
                    if(str[j]!='*')
                    {
                        swap(str[i],str[j]);
                        break;
                    }
                }
                ans++;
                c+=2;
            }
        }
        if(str[len-1]!='*'&&flag) ans++;
        printf("%d\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.