现在的位置: 首页 > 综合 > 正文

ZOJ 3819 Average Score 水

2017年11月23日 ⁄ 综合 ⁄ 共 1776字 ⁄ 字号 评论关闭

Average Score


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

"Too bad! You made me so disappointed."

"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

Now, you are given the scores of all students in the two classes, except for the Bob's. Please calculate the possible range of Bob's score. All scores shall be integers within [0, 100].

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob's class and the number
of students in the other class respectively.

The next line contains N - 1 integers A1A2, .., AN-1 representing the scores of other students in Bob's
class.

The last line contains M integers B1B2, .., BM representing the scores of students in the other class.

Output

For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

It is guaranteed that the solution always exists.

Sample Input

2
4 3
5 5 5
4 4 3
6 5
5 5 4 5 3
1 3 2 2 1

Sample Output

4 4
2 4

Author: JIANG, Kai
Source: The 2014 ACM-ICPC Asia Mudanjiang Regional Contest

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int INF=0x3f3f3f3f;

int n,m;
int suma,sumb;

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%d%d",&n,&m);
        suma=sumb=0;
        for(int i=0;i<n-1;i++)
        {
            int x;
            scanf("%d",&x);
            suma+=x;
        }
        for(int i=0;i<m;i++)
        {
            int x;
            scanf("%d",&x);
            sumb+=x;
        }
        int MIN=INF,MAX=-INF;
        for(int i=0;i<=100;i++)
        {
            if((suma*n>(suma+i)*(n-1))&&(sumb*(m+1)<(sumb+i)*m))
            {
                MIN=min(MIN,i);
                MAX=max(MAX,i);
            }
        }
        printf("%d %d\n",MIN,MAX);
    }
    return 0;
}

抱歉!评论已关闭.