现在的位置: 首页 > 综合 > 正文

1885Key Task(BFS+状态压缩)(胜利大逃亡续)一个意思

2017年12月12日 ⁄ 综合 ⁄ 共 3375字 ⁄ 字号 评论关闭

Key Task

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1229    Accepted Submission(s): 493

Problem Description
The Czech Technical University is rather old — you already know that it celebrates 300 years of its existence in 2007. Some of the university buildings are old as well. And the navigation in old buildings can sometimes be a little
bit tricky, because of strange long corridors that fork and join at absolutely unexpected places.

The result is that some first-graders have often di?culties finding the right way to their classes. Therefore, the Student Union has developed a computer game to help the students to practice their orientation skills. The goal of the game is to find the way
out of a labyrinth. Your task is to write a verification software that solves this game.

The labyrinth is a 2-dimensional grid of squares, each square is either free or filled with a wall. Some of the free squares may contain doors or keys. There are four di?erent types of keys and doors: blue, yellow, red, and green. Each key can open only doors
of the same color.

You can move between adjacent free squares vertically or horizontally, diagonal movement is not allowed. You may not go across walls and you cannot leave the labyrinth area. If a square contains a door, you may go there only if you have stepped on a square
with an appropriate key before.

 

Input
The input consists of several maps. Each map begins with a line containing two integer numbers R and C (1 ≤ R, C ≤ 100) specifying the map size. Then there are R lines each containing C characters. Each character is one of the following:

Note that it is allowed to have

  • more than one exit,
  • no exit at all,
  • more doors and/or keys of the same color, and
  • keys without corresponding doors and vice versa.

    You may assume that the marker of your position (“*”) will appear exactly once in every map.

    There is one blank line after each map. The input is terminated by two zeros in place of the map size.

  •  

    Output
    For each map, print one line containing the sentence “Escape possible in S steps.”, where S is the smallest possible number of step to reach any of the exits. If no exit can be reached, output the string “The poor student is trapped!”
    instead.

    One step is defined as a movement between two adjacent cells. Grabbing a key or unlocking a door does not count as a step.

     

    Sample Input
    1 10 *........X 1 3 *#X 3 20 #################### #XY.gBr.*.Rb.G.GG.y# #################### 0 0
     

    Sample Output
    Escape possible in 9 steps. The poor student is trapped! Escape possible in 45 steps.
     

    每个格子都有不同的状态,关键是在判断在走到当前格子的当前key状态是否走过。

    #include<stdio.h>
    #include<queue>
    #include<iostream>
    #include<string.h>
    using namespace std;
    #define N 105
    struct locate
    {
        int x,y,step,state;
    };
    char map[N][N];
    int state[N][N][16],n,m;
    
    int BFS(int sx,int sy)
    {
        queue<locate>q;
        locate p,tp;
        int dir[4][2]={0,1,1,0,0,-1,-1,0};
        char door[6]={"BYRG"},key[6]={"byrg"};
    
        memset(state,0,sizeof(state));
        p.step=0; p.state=0;
        p.x=sx; p.y=sy;
        q.push(p); state[sx][sy][0]=1;
    
        while(!q.empty())
        {
            p=q.front(); q.pop();
            for(int e = 0;e < 4;++e)
            {
                tp.x=p.x+dir[e][0];
                tp.y=p.y+dir[e][1];
    
                if(tp.x>=0&&tp.x<n&&tp.y>=0&&tp.y<m&&map[tp.x][tp.y]!='#'&&!state[tp.x][tp.y][p.state])
                {
                    tp.step=p.step+1;
                    tp.state=p.state;
                    if(map[tp.x][tp.y]=='X')
                        return tp.step;
                    int flag=0;
                    for(int i=0;i<4;i++)
                        if(map[tp.x][tp.y]==key[i])
                        {
                            flag=1; tp.state|=(1<<i);break;
                        }
                    state[tp.x][tp.y][tp.state]=1;
                    if(!flag)
                    {
                        flag=0;
                        for(int i=0;i<4;i++)
                            if(map[tp.x][tp.y]==door[i])
                            {
                                flag=1;
                                if(tp.state&(1<<i))
                                    flag=2;
                                break;
                            }
                        if(flag!=1)
                            q.push(tp);
                    }
                    else
                        q.push(tp);
                }
            }
        }
        return 0;
    }
    
    int main()
    {
        int sx,sy;
        while(scanf("%d%d",&n,&m)>0)
        {
            if(n==0&&m==0)
                break;
            for(int i=0;i<n;i++)
                scanf("%s",map[i]);
            for(int i=0;i<n;i++)
                for(int j=0;j<m;j++)
                if(map[i][j]=='*')
                sx=i,sy=j;
            int ans=BFS(sx,sy);
            if(ans)
                printf("Escape possible in %d steps.\n",ans);
            else
                printf("The poor student is trapped!\n");
        }
    }
    

    抱歉!评论已关闭.