现在的位置: 首页 > 综合 > 正文

hdu1072 Nightmare (BFS)

2017年12月13日 ⁄ 综合 ⁄ 共 3796字 ⁄ 字号 评论关闭
Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is
set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute)
takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1

Sample Output
4 -1 13
题目的意思:就是要从起始位置到终到时,那炸弹没有炸,时间为0时就会炸,即使到了出口也不能出去,
0不能起,1走得通,2是起始的位置,3是出口,4是调时器,在当前位置把定时炸弹时间调为6;
#include<stdio.h>
#include<queue>
#include<string.h>
#include<iostream>
using namespace std;
typedef struct nn
{
    int x,y,time,step;
}node;
int sx,sy,dx,dy,h,w,map[10][10],Step,vist[10][10];
int dir[4][2]={{1,0},{-1,0},{0,-1},{0,1}};
queue<node> QQ;//用来装调时器的,下面看就会懂了
void BFS()
{
    queue<node> Q;
    node q,p;
    int e,tx,ty;
    if(sx==dx&&sy==dy)//首先判断
    {
        Step=0;return ;
    }
    q.step=0;q.time=6;q.x=sx;q.y=sy;
    vist[sy][sx]=1;     //表示走过
    Q.push(q);
    while(!Q.empty())
    {
        q=Q.front();
        Q.pop();
        if(q.time>1)
        for(e=0;e<4;e++)
        {
            tx=q.x+dir[e][0]; ty=q.y+dir[e][1];
            if(tx>=0&&tx<w&&ty>=0&&ty<h&&map[ty][tx]!=0&&!vist[ty][tx])
            {
                p.step=q.step+1; p.time=q.time-1;
                p.x=tx; p.y=ty;
                vist[ty][tx]=1;
                if(tx==dx&&ty==dy)//找到
                {
                    Step=p.step;return ;
                }
                if(map[ty][tx]==4)//当为调时器时,先暂时不走这路线,放入QQ队列,
                {
                    p.time=6;  //当时时间设成6
                    QQ.push(p);
                    continue ;
                }
                Q.push(p);
            }
        }
    }
}
int main()
{
    int t,x,y,e,tx,ty;
    node q,p;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&h,&w);
        for(y=0;y<h;y++)
        for(x=0;x<w;x++)
        {
            scanf("%d",&map[y][x]);
            if(map[y][x]==2)
            {
                sx=x;sy=y;
            }
            if(map[y][x]==3)
            {
                dx=x;dy=y;
            }
        }
        memset(vist,0,sizeof(vist));
        Step=-1;
        BFS();
        if(Step==-1)//当上一个找不到时
        {
            memset(vist,0,sizeof(vist));
        while(!QQ.empty())//开始走没有走过的路线
        {
            q=QQ.front();
            QQ.pop();
            if(q.time>1)
            for(e=0;e<4;e++)
            {
                tx=q.x+dir[e][0]; ty=q.y+dir[e][1];
                if(tx>=0&&tx<w&&ty>=0&&ty<h&&map[ty][tx]!=0&&!vist[ty][tx])
                {
                    p.step=q.step+1; p.time=q.time-1;
                    p.x=tx; p.y=ty;
                    vist[ty][tx]=1;
                    if(tx==dx&&ty==dy)
                    {
                        Step=p.step; break ;
                    }
                    if(map[ty][tx]==4)//为4时,又把当前位置设成6
                        p.time=6;
                    QQ.push(p);
                }
            }
            if(Step!=-1)//找到了,跳出
            break;
        }
        }
        printf("%d\n",Step);
    }
}

抱歉!评论已关闭.