现在的位置: 首页 > 综合 > 正文

hdu1728逃离迷宫 (利用最短路径思想+优先队列(BFS))

2017年12月13日 ⁄ 综合 ⁄ 共 1743字 ⁄ 字号 评论关闭
Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2
≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。

Sample Input
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3

Sample Output
no yes
解题思路:利用最短路径思想,从终点出发,把每个点到终点的最小转折数算出来。
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
typedef struct nod
{
    int direct,turn,x,y;
    friend bool operator <(nod n1,nod n2)
    {
        return n2.turn<n1.turn;
    }
}node;
int h,w,sx,sy,dx,dy,maxturn,flog;
int N[105][105];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
char map[105][105];

void BFS()
{
    int e,tx,ty;
    priority_queue<node>Q;
    node q,p;
    q.x=dx-1;q.y=dy-1;q.direct=-1;q.turn=0;
    Q.push(q);N[dy-1][dx-1]=0;
    while(!Q.empty())
    {
        q=Q.top();
        Q.pop();
        if(q.turn>maxturn)
            continue;
        for(e=0;e<4;e++)
        {
            tx=q.x+dir[e][0];ty=q.y+dir[e][1];
            if(tx>=0&&tx<w&&ty>=0&&ty<h&&map[ty][tx]!='*')
            {
                p.direct=e; p.x=tx; p.y=ty; p.turn=q.turn;
                if(q.direct>=0&&q.direct!=e)
                        p.turn++;
                if(N[ty][tx]>=p.turn)
                   {
                       N[ty][tx]=p.turn;
                       Q.push(p);//printf("%d %d\n",q.turn,e);
                   }
            }
        }
    }
    if(N[sy-1][sx-1]<=maxturn)
    flog=1;
}
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&h,&w);
        getchar();
        for(i=0;i<h;i++)
        {
            for(j=0;j<w;j++)
            {
                scanf("%c",&map[i][j]);
                N[i][j]=10000000;
            }
            getchar();
        }
        scanf("%d%d%d%d%d",&maxturn,&sx,&sy,&dx,&dy);
        flog=0;
        BFS();
        
        printf("%s\n",flog?"yes":"no");
    }
}

抱歉!评论已关闭.