现在的位置: 首页 > 综合 > 正文

斯特灵数 hdu 3625

2017年12月13日 ⁄ 综合 ⁄ 共 3224字 ⁄ 字号 评论关闭

这是个斯特灵数的问题,跟卡塔兰数一样,根本没听过……但是感觉挺实用的……

斯特灵数一共分两类,这个是第一类……维基百科:点击打开链接

##########################################################################################################

第一类Stirling数是有正负的,其绝对值是n个元素的项目分作k个环排列的方法数目。常用的表示方法有s(n,k) , \left[\begin{matrix} n \\ k \end{matrix}\right]

换个较生活化的说法,就是有n个人分成k组,每组内再按特定顺序围圈的分组方法的数目。

递归关系s(n+1,k)=s(n,k-1) + n \; s(n,k)

###########################################################################################################

第二类Stirling数是n个元素的集定义k个等价类的方法数目。常用的表示方法有S(n,k) , S_n^{(k)} ,  \left\{\begin{matrix} n \\ k \end{matrix}\right\}

换个较生活化的说法,就是有n个人分成k组的分组方法的数目。

递归关系S(n,k) = S(n-1,k-1) + k S(n-1,k)

###########################################################################################################

题目

Examining the Rooms

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 509 Accepted Submission(s): 294
 
Problem Description
A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap! You know that there is exactly
one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and the key for Room 1 is numbered
Key 1, the key for Room 2 is Key 2, etc.
To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch
the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force,
then repeat the procedure above, until all the rooms are examined.
Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You
want to know what is the possibility of that you can examine all the rooms finally.
 
Input
The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)
 
Output
Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.
 
Sample Input
3
3 1
3 2
4 2
 
Sample Output
0.3333
0.6667
0.6250
Hint
Sample Explanation When N = 3, there are 6 possible distributions of keys: Room 1 Room 2 Room 3 Destroy Times #1 Key 1 Key 2 Key 3 Impossible #2 Key 1 Key 3 Key 2 Impossible #3 Key 2 Key 1 Key 3 Two #4 Key 3 Key 2 Key 1 Two #5 Key 2 Key 3 Key 1 One #6 Key 3 Key 1 Key 2 One In the first two distributions, because Key 1 is locked in Room 1 itself and you can’t destroy Room 1, it is impossible to open Room 1. In the third and forth distributions, you have to destroy Room 2 and 3 both. In the last two distributions, you only need to destroy one of Room 2 or Room
 

##代码

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<string.h>
#include<math.h>
#include<limits.h>
#include<memory.h>
#define MAX a>b?a:b;
using namespace std;
#define MA 0x3f3f3f3f
long long s[25][25],d[25];
int main()
{
    int t,n,k;
    cin >> t;
    int i,j;
    d[0]=1;
    for(i=1;i<25;i++)
    {
        s[i][0]=0;
        s[i][i]=1;
        d[i]=d[i-1]*i;
    }
    for(i=2;i<25;i++)
        for(j=1;j<i;j++)
            s[i][j]=s[i-1][j-1]+(i-1)*s[i-1][j];
    //cout << s[10][1] <<' '<< s[15][2] << endl;
    while(t--)
    {
        cin >> n >> k ;
        long long j=0;
        for(i=1;i<=k;i++)
            j+=s[n][i]-s[n-1][i-1];
        //cout << d[n] << ' ' << j<<endl;
        printf("%.4f\n",(double)j/d[n]);
    }
    return 0;
}

抱歉!评论已关闭.