现在的位置: 首页 > 综合 > 正文

Stones (2013.09.15周赛)

2018年01月12日 ⁄ 综合 ⁄ 共 1665字 ⁄ 字号 评论关闭

D. Stones

3000ms
3000ms
32768KB
64-bit integer IO format: %I64d      Java class name: Main
Font Size:  
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 

There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell
me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 

For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position
of the i-th stone and how far Sempr can throw it.

Output

Just output one line for one test case, as described in the Description.

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12

这道题其实就是优先队列的运用。要注意一下优先队列的使用。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
using namespace std;
struct node
{
    int p,d;
    friend bool operator <(node s, node v)
    {
        if (s.p!=v.p) return s.p>v.p;
        return s.d>v.d;
    }
};

int main ()
{
    int t,n,i,j;
    cin>>t;
    while(t--)
    {
        cin>>n;
        node e;
        priority_queue<node> q;
        for (i=0; i<n; i++)
        {
            scanf("%d%d",&e.p,&e.d);
            q.push(e);
        }
        int k=1,max=0;
        while(!q.empty())
        {
            e=q.top();
            q.pop();
            if (k%2)
            {
                e.p=e.d+e.p;
                if (e.p>max) max=e.p;
                q.push(e);
            }
            k++;
        }
        cout<<max<<endl;
    }
    return 0;
}

抱歉!评论已关闭.