现在的位置: 首页 > 综合 > 正文

POJ 1111 Image Perimeters (DFS)

2018年01月12日 ⁄ 综合 ⁄ 共 3648字 ⁄ 字号 评论关闭
Image Perimeters
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6889   Accepted: 4104

Description

Technicians in a pathology lab analyze digitized images of slides. Objects on a slide are selected for analysis by a mouse click on the object. The perimeter of the boundary of an object is one useful measure. Your task is to determine this perimeter for selected
objects. 

The digitized slides will be represented by a rectangular grid of periods, '.', indicating empty space, and the capital letter 'X', indicating part of an object. Simple examples are 

XX   Grid 1       .XXX   Grid 2 

XX                .XXX 

                  .XXX 

                  ...X 

                  ..X. 

                  X... 

An X in a grid square indicates that the entire grid square, including its boundaries, lies in some object. The X in the center of the grid below is adjacent to the X in any of the 8 positions around it. The grid squares for any two adjacent X's overlap on
an edge or corner, so they are connected. 

XXX 

XXX    Central X and adjacent X's 

XXX 

An object consists of the grid squares of all X's that can be linked to one another through a sequence of adjacent X's. In Grid 1, the whole grid is filled by one object. In Grid 2 there are two objects. One object contains only the lower left grid square.
The remaining X's belong to the other object. 

The technician will always click on an X, selecting the object containing that X. The coordinates of the click are recorded. Rows and columns are numbered starting from 1 in the upper left hand corner. The technician could select the object in Grid 1 by clicking
on row 2 and column 2. The larger object in Grid 2 could be selected by clicking on row 2, column 3. The click could not be on row 4, column 3. 



One useful statistic is the perimeter of the object. Assume each X corresponds to a square one unit on each side. Hence the object in Grid 1 has perimeter 8 (2 on each of four sides). The perimeter for the larger object in Grid 2 is illustrated in the figure
at the left. The length is 18. 

Objects will not contain any totally enclosed holes, so the leftmost grid patterns shown below could NOT appear. The variations on the right could appear: 

Impossible   Possible 



XXXX         XXXX   XXXX   XXXX 

X..X         XXXX   X...   X... 

XX.X         XXXX   XX.X   XX.X 

XXXX         XXXX   XXXX   XX.X 



.....        .....  .....  ..... 

..X..        ..X..  ..X..  ..X.. 

.X.X.        .XXX.  .X...  ..... 

..X..        ..X..  ..X..  ..X.. 

.....        .....  .....  ..... 

Input

The input will contain one or more grids. Each grid is preceded by a line containing the number of rows and columns in the grid and the row and column of the mouse click. All numbers are in the range 1-20. The rows of the grid follow, starting on the next line,
consisting of '.' and 'X' characters. 

The end of the input is indicated by a line containing four zeros. The numbers on any one line are separated by blanks. The grid rows contain no blanks. 

Output

For each grid in the input, the output contains a single line with the perimeter of the specified object.

Sample Input

2 2 2 2
XX
XX
6 4 2 3
.XXX
.XXX
.XXX
...X
..X.
X...
5 6 1 3
.XXXX.
X....X
..XX.X
.X...X
..XXX.
7 7 2 6
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
7 7 4 4
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
0 0 0 0

Sample Output

8
18
40
48
8

题意:

给定n*m的方格,给出(x,y)的坐标。

其中只要与“X"的相邻的八个位置有”X",则表示在该区域。


解题思路:

首先就是用DFS来搜索出总共有多少个X相连,然后用变量来标记每个X的上下左右四个方向有多少个X,在求周长的时候减去即可。(在代码中有具体解释)

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[22][22], map[22][22],n,m,x,y,pe,pi;
int dir[8][2]={-1,-1,-1,0,-1,1,0,-1,1,-1,0,1,1,1,1,0};
int inside(int xx, int yy)
{
    if (xx>0 && xx<=n && yy>0 && yy<=m)
        return 1;
    else
        return 0;
}
int find(int xx, int yy)
{
    int i,j;
    pi++;//用pi来记录总共有多少个X相连。
    map[xx][yy]=1;
    for (i=0; i<8; i++)
    {
        int tempx,tempy;
        tempx=xx;
        tempy=yy;
        tempx+=dir[i][0];
        tempy+=dir[i][1];
        if ((a[tempx][tempy]==1) && inside(tempx,tempy) && (map[tempx][tempy]==0))
        {
            find(tempx,tempy);
            for (j=1; j<8; j+=2)
                if (a[tempx+dir[j][0]][tempy+dir[j][1]]==1)
                    pe--;//相对一个X,如果上下左右没有相邻的X,则周长便是4。有i个相邻,便减少i
        }
    }
}
int main ()
{
    int i,j;
    char ch;
    while(scanf("%d%d%d%d",&n,&m,&x,&y))
    {
        if (n==0) break;
        memset(a,0,sizeof(a));
        memset(map,0,sizeof(map));
        pe=0;
        pi=0;
        for (i=1; i<=n; i++)
            for (j=1; j<=m; j++)
            {
                cin>>ch;
                if (ch=='X')
                    a[i][j]=1;
            }
        find(x,y);
        for (j=1; j<8; j+=2)
            if (a[x+dir[j][0]][y+dir[j][1]]==1)
                pe--;       //这一步不能少,因为到最后填出find函数之后,(x,y)的周围还没有找过
        cout<<pi*4+pe<<endl;

    }
    return 0;
}


抱歉!评论已关闭.