现在的位置: 首页 > 综合 > 正文

POJ 1251 Jungle Roads

2018年01月12日 ⁄ 综合 ⁄ 共 2973字 ⁄ 字号 评论关闭
Jungle Roads
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17586   Accepted: 7937

Description



The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The
Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads,
even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through
I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet,
capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to
villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road.
Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more
than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute
time limit. 

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

题意:

有n个点,其中每个点与其它若干点相连。求最小生成树

这是道裸题,主要要熟悉一下Prime 和 krusical 两种算法

1. Prime 是每次选一个点进集合,然后找到集合内到集合外的最短路,把这条最短路的对应未进入集合的点加入集合。

2. Krusical 将所有路径按照从小到大排序,然后每次选择最短的路径加入集合(要求是路径两个端点中最少有一个点没有进入集合)。这里要用到并查集

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main ()//prime
{
    int n,i,j;
    char ch;
    while(cin>>n)
    {
        int t,s,k,sum=0;
        int map[30][30]={0};
        int low[30]={0},visit[30]={0};
        if (n==0) break;
        for (i=0; i<n; i++)
            for (j=0; j<n; j++)
                map[i][j]=10000;
        for (i=0; i<n-1; i++)
        {
            cin>>ch>>t;
            while(t>0)
            {
                cin>>ch>>s;
                map[i][ch-'A']=map[ch-'A'][i]=s;
                t--;
            }
        }
        visit[0]=1;
        for (i=0; i<n; i++)
            low[i]=map[0][i];
        for (i=1; i<n; i++)
        {
            int min=10000;
            for (j=0; j<n; j++)
                if (!visit[j] && low[j]<min)
                {
                    min=low[j];
                    k=j;
                }
            sum+=low[k];
            visit[k]=1;
            for (j=0; j<n; j++)
                if (!visit[j] && low[j]>map[k][j])
                    low[j]=map[k][j];
        }
        cout<<sum<<endl;
    }
    return 0;
}

抱歉!评论已关闭.