现在的位置: 首页 > 综合 > 正文

HDOJ 2602 Bone Collector (01背包)

2018年01月12日 ⁄ 综合 ⁄ 共 1499字 ⁄ 字号 评论关闭

Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18737 Accepted Submission(s): 7403

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output
14
解题思路:
终于会写背包了。hiahia~
之前用二维数组会因为数组太大而溢出。故可以进行空间优化,用一维数组来记录。
01背包问题
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main ()
{
    int t,n,m,j,i;
    int w[1005],vl[1005],dp[1005];
    cin>>t;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(w,0,sizeof(w));
        memset(vl,0,sizeof(vl));
        memset(dp,0,sizeof(dp));
        for (i=1; i<=n; i++)
            scanf("%d",w+i);
        for (j=1; j<=n; j++)
            scanf("%d",vl+j);
        for (i=1; i<=n; i++)
            for (j=m; j>=vl[i]; j--)
                if (dp[j]<dp[j-vl[i]]+w[i])
                    dp[j]=dp[j-vl[i]]+w[i];
        cout<<dp[m]<<endl;
    }
    return 0;
}

抱歉!评论已关闭.